Forum OpenACS Development: Re: Is it possible to create a new package in Project Open - OpenACS?

Hello Prabu,
welcome to the community and I'm sorry to hear you're having difficulties creating a new package. Did you see the tutorial here? http://openacs.org/doc/current/tutorial.html

Maybe if you give a description of what you're trying to achieve, then you will be able to receive more specific help.

Good luck!
Brian

Hello Brian,

I found that in the document, .sql file should be execute in the shell prompt.

[$OPENACS_SERVICE_NAME postgresql]$ psql -f myfirstpackage-create.sql

:-)

Thanks again

Glad to hear it! :-)
Hello Brian,

I have followed the document and created the package called notes. 

when i was tried to add a title of the notes (through new application, notes), i got the following error..


 Here is a detailed dump of what took place at the time of the error, which may assist a programmer in tracking down the problem:

    Required switch -item_id not provided
        while executing
    "mfp::note::add__arg_parser"
        (procedure "mfp::note::add" line 1)
        invoked from within
    "mfp::note::add  -title $title"
        ("uplevel" body line 2)
        invoked from within
    "uplevel #$level $new_data"
        ("1" arm line 1)
        invoked from within
    "switch $errno {
                        0 {
                            # TCL_OK
                        }
                        1 {
                            # TCL_E..."
        (procedure "ad_form" line 612)
        invoked from within
    "ad_form -name note -form {
        {item_id:key}
        {title:text {label Title}}
    } -new_request {
        auth::require_login
        permission::require_permissio..."
        ("uplevel" body line 13)
        invoked from within
    "uplevel {
              ad_page_contract {
        This is the view-edit page for notes.

        @author Your Name (mailto:you@example.com)
        @cvs-id $Id: tutorial-pages..."
        (procedure "code::tcl::/home/projop/packages/intranet-notes/www/note-edi..." line 2)
        invoked from within
    "code::tcl::$__adp_stub"
        invoked from within
    "if { [file exists $__adp_stub.tcl] } {

          # ensure that data source preparation procedure exists and is up-to-date
          adp_init tcl $__adp_stub
    ..."
        ("uplevel" body line 3)
        invoked from within
    "uplevel {

        if { [file exists $__adp_stub.tcl] } {

          # ensure that data source preparation procedure exists and is up-to-date
          adp_init t..."
        (procedure "adp_prepare" line 2)
        invoked from within
    "adp_prepare "
        (procedure "template::adp_parse" line 30)
        invoked from within
    "template::adp_parse [file root [ad_conn file]] {}"
        (procedure "adp_parse_ad_conn_file" line 5)
        invoked from within
    "$handler"
        ("uplevel" body line 2)
        invoked from within
    "uplevel $code"
        invoked from within
    "ad_try {
                    $handler
                } ad_script_abort val {
                    # do nothing
                }"
        invoked from within
    "rp_serve_concrete_file [ad_conn file]"
        (procedure "rp_serve_abstract_file" line 60)
        invoked from within
    "rp_serve_abstract_file "$root/$path""
        ("uplevel" body line 2)
        invoked from within
    "uplevel $code"
        invoked from within
    "ad_try {
                rp_serve_abstract_file "$root/$path"
                set tcl_url2file([ad_conn url]) [ad_conn file]
                set tcl_url2path_info..."



Could you please help to fix this issue...

Thanks