Home
The Toolkit for Online Communities
17599 Community Members, 0 members online, 2569 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : Problem Installing The Jabber Package : One Message

Forum OpenACS Q&A: Re: Problem Installing The Jabber Package

Collapse
Posted by Steve Manning on
Thanks but sorry you've lost me there. Do you mean in jpacket.c or in jabber.h? Do you mean ctrl-z cos I can't find any?

  Steve
Collapse
Posted by Andrew Piskorski on
The compiler is saying claiming that you have some kind of mistake in your source files. It wouldn't hurt to go look at line 59 of jabber.h and see if there's anything weird in that general vicinity (like you hit a key by accident when you had that file open in your editor).

What Michel is suggestion above is that perhaps the problem is due to your source files having DOS/Windows line endings on a Unix machine. I'm assuming you're doing this on a Linux box or the like, so dun fromdos or dos2unix on jabber.h and see if that changes the file at all. If it does, you had the wrong line endings.

Collapse
Posted by Steve Manning on
Thanks Andrew

Before I posted I'd already looked around the jabber.h source file at line 59 because I was thinking the same thing. I've looked at a hex dump of the file and I can't see anything other than ASCII 0x20 for the spacing and 0x0A for the line feeds.There is nothing hiding that I can see. The area around line 59 looks like this with line 59 being the  pool p; line:

#define JID_RESOURCE 1
#define JID_USER    2
#define JID_SERVER  4

typedef struct jid_struct {
    pool              p;
    char*              resource;
    char*              user;
    char*              server;
    char*              full;
    struct jid_struct *next; /* for lists of jids */
} *jid;

jid    jid_new(pool p, char *idstr);          /* Creates a jabber id from the idstr */

I'm wondering if there is something hiding above this in the file and this is causing the compiler to barf at line 59.

The file is striaght out of the OACS contribs on the CVS. Prior to getting this problem I did nothing more than untar it, copy into my AOLServer dir and run the make - its weird. Has anyone succesffully compiled this package previously?