Home
The Toolkit for Online Communities
16701 Community Members, 1 member online, 2575 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Development : oacs-4-6 HEAD broken, use 4-6-1-b2

Forum OpenACS Development: oacs-4-6 HEAD broken, use 4-6-1-b2

Icon of envelope Request notifications

Collapse
Posted by Lars Pind on
I committed our new APM changes, workflow, bug-tracker, ticket-tracker, etc., to the oacs-4-6 branch yesterday, and there are two unresolved issued with the APM, which Peter will address when he gets back from Portugal on Monday:

- Upgrade of acs-kernel from 4.6.1 to 4.6.2 cannot be done via APM. You have to source the upgrade script manually, then update acs-kernel, acs-tcl, acs-admin, and acs-bootstrap-installer in one go (sources only, only acs-kernel has a DB upgrade script), before you start your server.

- Peter removed the file listings from the .info files and changed the APM so it relies on what files are in the file system, instead of what's listed in the .info file. Unfortunately, the new code doesn't find portal-create.sql, because it's looking for new-portal-create.sql; and in forums, it finds both forums-create.sql and forums-forums-create.sql.

Those are the things I'm aware of. They'll get fixed on
Monday.

Meanwhile, the recommended tag is oacs-4-6-1-b2.

/Lars

Collapse
Posted by Mohan Pakkurti on
Collapse
Posted by Lars Pind on
Yes.

Peter will fix on Monday.

(I renamed the portal-create.sql script to new-portal-create.sql, which should fix it for portals, actually, but I didn't test.)

/Lars