Home
The Toolkit for Online Communities
17513 Community Members, 1 member online, 2224 visitors today
Log In Register
OpenACS Home : Forums : .LRN Q&A : Help with dotlrn-ecommerce

Forum .LRN Q&A: Help with dotlrn-ecommerce

Icon of envelope Request notifications

Collapse
Posted by Rob Mayhue on
Hi Everyone,

I'm trying to get the dotlrn-ecommerce package setup for a new client of ours that wants to sell their online courses as well as some instructional CD's but I'm having a little trouble figuring out how to get the package configured properly and that's assuming that I even have the package and all of the required dependencies installed correctly. :)

This this what I currently have installed:
AOLServer-4.0.10
PostgreSQL-7.4.17
tcl-8.4.14
tcllib-1.9
xotcl-1.5.3
dotLRN-2.2.1 (tar.gz) (OpenACS-5.2.3)

The following packages were pulled from cvs.openacs.org:
attendance-0.1d (HEAD)
authorize-gateway-4.6 (HEAD)
dotlrn-attendance-0.1d (HEAD)
dotlrn-catalog-0.1a5 (oacs-5-2)
dotlrn-ecommerce-0.1d26 (HEAD)
ecommerce-5.05 (oacs-5-2)
payment-gateway-4.6 (HEAD)
ref-countries-1.1 (oacs-5-2)
ref-language-0.1d (oacs-5-2)
ref-us-counties-0.1d (oacs-5-2)
ref-us-states-0.1d (oacs-5-2)
ref-us-zipcodes-2.0 (oacs-5-2)
scholarship-fund-0.7d (HEAD)
wp-slim-5.0d1 (openacs-5-1-compat)
wps-portlet-2.0.2 (HEAD)

With the exception of the payment-gateway and authorize-gateway packages the above package list was determined from the dependencies of the dotlrn-ecommerce package and in turn any dependencies of those required packages. Most everything seemed to install with only minor errors and warnings. I corrected (I think anyhow) all of the obvious errors I could find in the error log but being relatively new to Tcl, OpenACS and dotLRN I still have a lot of things to learn and this is where I need the experience and advice of someone who has the dotlrn-ecommerce package installed and running in production as I couldn't find any documentation for the version in CVS. I have read everything I could find on the Solution Grove website regarding that version of the package and while that helped me to understand most of the basic functionality of the package, from what I can tell, there are several differences between the two.

I took a guess and mounted the dotlrn-ecommerce and Ecommerce instances right below the main site but I'm getting some errors when I click some of the links in the admin section and I think the errors are either due to the fact that some of the other packages need to be configured/setup properly in advance or maybe some of the package versions are wrong etc. It could also be due to the fact there is ongoing work being done to the dotlrn-ecommerce package because I did notice some recent commits in CVS.

Here are some of the (shortened) errors I'm getting in the admin section:

- Manage Registration Assessment
error:
Query did not return any rows. "db_1row get_course "select * from dotlrn_catalog, cr_items where item_id=:course_id and course_id=latest_revision"

- Waiting List and Prerequisite Applications
- Users in Waiting List
- Approved Users in Waiting List
- Users for Prerequisite Approval
- Approved Users for Prerequisite Approval

All the above links produce this error:
invalid command name "as::list::params"

- View Orders
- In the last 24 hours
- In the last week

All the links above produce this error:
Database operation "select" failed (exception NSDB, "Query was not a statement returning rows.")

- Manage Category Trees
error:
Query did not return any rows. "db_1row get_course "select * from dotlrn_catalog, cr_items where item_id=:course_id and course_id=latest_revision"

I would very much appreciate any help that anyone can give me regarding dotlrn-ecommerce package or if anyone can point me to some documentation that might help me.

Thank you.

Collapse
Posted by Dave Bauer on
You need dotlrn 2.3.0 for dotlrn-ecommerce. It might not be reflected in the dependencies.

This error which I see more than once:
Query did not return any rows. "db_1row get_course "select * from dotlrn_catalog, cr_items where item_id=:course_id and course_id=latest_revision"

It looks like your data in dotlrn-catalog is not setup correctly. Did you create a course or section?

Collapse
Posted by Rob Mayhue on
The would be great if I can use dotlrn 2.3.0 because the zen theme would work much better for me but its based on OpenACS 5.3.1 and I've never been able to get the Ecommerce package to install under OpenACS 5.3.1.

The error I'm getting is:
Error: apm_package_install: Error installing E-Commerce version 5.05: psql:ecommerce-create.sql:51: ERROR: syntax error at or near "(" at character 22
psql:ecommerce-create.sql:51: LINE 1: create function least(numeric,numeric)

That was on a test server running dotlrn-2.3.0 with postgresql-8.1.8 installed. Since this is a database error I'm thinking that it must be the difference between postgresql-7.4.17 and postgresql-8.1.8.

If it is a database issue is there a fix for getting Ecommerce 5.0.5 installed on postgresql-8.x versions? According to the compatibility matrix OpenACS 5.3 core cannot use postgresql-7.4.x

Concerning the error you quoted - no I have not yet created a course or section. I'm guessing that error will go away when I do.

Thank you.

Collapse
Posted by Dave Bauer on
It looks like least is a built-in function on 8.x.

So it looks like the query errors should be guarded to return gracefully if no courses exist yet, and the dependencies should be updated.

I am using dotlrn-ecommerce with ecommerce on PG 8.1 so it does function. This was an upgrade for 7.4 to 8.1 so it must have just skipped over the error creating the least function when I reloaded the database.

Collapse
Posted by Dan Fuller on
I'm also trying to install dotlrn's e-commerce package, but I'm having some trouble sorting out the dependencies. I have dotlrn 2.3.0 installed along with PostgreSQL 8.2.4.

My installation is also failing when attempting to install the OpenACS e-commerce module. From looking through the forums, it appears that the OpenACS e-commerce module is incompatible with anything past version 5.1. Since dotlrn 2.3.0 is based on OpenACS 5.3 (correct?), what version of dotlrn should I be using to successfully install e-commerce?

Thanks,
-dan

Collapse
Posted by Dave Bauer on
Looks like you need ecommerce from the oacs-5-2 branch in CVS to make this work.