Home
The Toolkit for Online Communities
17705 Community Members, 0 members online, 3954 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : Search and OpenFTS : One Message

Forum OpenACS Q&A: Re: Search and OpenFTS

Collapse
16: Re: Search and OpenFTS (response to 15)
Posted by James Bennin on
I think I have found the file you've been talking about. I think it is the "sample-config.tcl" file. I have also read some the aolserver documentation and found some files about configuration. In that specific file the line for configuring the mail was written as such:
ns_param   mailhost        smtp.yourcompany.com ;# SMTP host for ns_sendmail

So I replaced it with "sendmail" since that is the SMTP we are using.

ns_param   mailhost        sendmail;# SMTP host for ns_sendmail

But I am still getting some errors.
Collapse
17: Re: Search and OpenFTS (response to 16)
Posted by Jarkko Laine on
James,

Sendmail is not your smtp host, it's the mail server program used _on_ your host. SMTP host means the address of your server, something like smtp.ourdomain.com. In most cases it's "localhost" if you're not using a different server for mail handling. Please try that and let us know if it works.

Collapse
18: Re: Search and OpenFTS (response to 17)
Posted by James Bennin on
Thank you for trying to help me out. I tried every different parameter name possible from localhost to my ip address, and even smtp.mycompany.com (of course I replaced it with the real name), and I still get the
[2426.147467][-sched:8-] Error: ns_sendmail failed: could not connect to "localhost:25"
I am doing the modification under the sample-config.tcl file found on the "/usr/local/aolserver/" folder. Is it the right file? What else should I do?
Collapse
19: Re: Search and OpenFTS (response to 18)
Posted by Tilmann Singer on
You need to find out which smtp server your system is able to use for sending email, and then set the parameter accordingly. Most linux installations have one running locally, but maybe you don't - what's the setting for smtp server in your mail program, in case you use one on that machine?

You can also try to connect to the mailserver from the commandline with something like this:

tils@tp:~$ telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 tils.net ESMTP
If you don't get a response like the one above than most likely there is no mailserver running on that system.

I hope that makes at least a bit sense.

Collapse
20: Re: Search and OpenFTS (response to 18)
Posted by Jarkko Laine on
hmmm... the right file is the one you are referencing to when you launch aolserver. It doesn't matter that much where it lies, you just have to point nsd to read that file when you start it.

Regarding your error, do you have an MTA (like sendmail) listening to 25 on your box?

Collapse
21: Re: Search and OpenFTS (response to 18)
Posted by Joel Aufrecht on
I'm not sure where this thread switched from search to email. However, one thing to test is that you have a mailserver running. One way to do that is telnet localhost 25. If you get a connection(
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 localhost ESMTP
) then you can try HELO and it should answer 250 localhost. None of this has anything to do with OpenACS. If you can't get this far, then the problem is with the mail program, not OpenACS.