File storage currently creates a file-storage_1234 name for cr_items.name.
Generally it seems cr_items.name is used as the name of the item to be used in constructing a URL. This makes things very easy to find a content item or folder from a URL and is absolutely necessary to get WebDAV working with file-storage. Currectly the URL for the folder is not stored anywhere in the database for a file-storage package instance root folder.
Here is the code that names the folder:
v_folder_id := content_folder__new ( v_package_key || ''_'' || new_root_folder__package_id, -- name v_folder_name, -- label v_description, -- description null -- parent_id (default) );
So should I change this to accept a name parameter and use the site-node name for the file-storage package instance for the folder name?