Forum OpenACS Development: Re: Augmenting acs_objects - adding package_id, name, and clarifying other fields

I don't think is the same as would be. is a terrible misnomer - it should be sth like cr_items.urlpart since that's what it is. (should) containĀ  a short, lowercase identifier with url compatible characters only, and unique within a particular content folder. All requirements that wouldn't have. The pretty name of a cr_item can be found in cr_revisions.title instead. would ideally duplicate the cr_revisions.title of the live revision, or last revision if there is no live revision.

Adding would centralize a facility that many packages have already - to store a pretty user displayable name for specific objects. E.g. forums_messages.subject or It would propably be advisable for the packages to move storage of name over to the centralised service. Or think about doing all this in the CR (sorry just rambling).

If it goes into acs_objects, then a null value in could become 'One acs_object_types.pretty_name', e.g. 'One User Portrait' when displayed.