Forum .LRN Q&A: Re: Server recommend for dotLRN - with 80.000 users-

Collapse
Posted by Andrew Piskorski on
Cato, my guess is you have your AOLserver threadtimeout set much too low, which is worth experimenting with and changing.

Why do you have so many more connections in your 2nd database pool than in your first? That seems weird.

On both machines, leaving the P4 hyperthreading turned on is also probably a bad idea unless you have a kernel (Linux 2.6.x, I think) which distinguishes between real and virtual/hyperthread processors.

Collapse
Posted by Cato Kolås on
> Cato, my guess is you have your AOLserver threadtimeout set
> much too low, which is worth experimenting with and
> changing.

ok, will do. thx.

> Why do you have so many more connections in your 2nd
> database pool than in your first? That seems weird.

have turned on logging when pools are empty:
ns_param  WarnEmpty          true
- and based on the numbers of warnings tried to adjust the settings.

Collapse
Posted by Nima Mazloumi on
Hi Cato,
can you tell me what tool you use to log the load on the webserver and the database?

Greetings,
Nima

Collapse
Posted by Cato Kolås on
|Hi Cato,
|can you tell me what tool you use to log the load on the
|webserver and the database?

It's mrtg with a custom script to gather information about the load from the two machines (runs uptime via ssh connections and greps for the load).