Home
The Toolkit for Online Communities
17230 Community Members, 0 members online, 1871 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : Intranet Setup

Forum OpenACS Q&A: Intranet Setup

Icon of envelope Request notifications

Collapse
Posted by John Campbell on
I've installed and configured openacs-3.2.5-2 (via rpm) but am having
a problem setting up the Intranet module in a way that makes sense for
users on our Intranet.

I've setup the Intranet module and it appears to work. My problem
concerns how authorized users get to the Intranet. For instance, if I
login as <user>, I get to "My Workspace", there is no link to the
Intranet. They have to manually type in "/intranet" after
<hostname:8000> to get to it. What I want is for users to login and
get straight to the intranet page, since "My Workspace" is not
especially useful. How would I go about doing this?

Collapse
2: Response to Intranet Setup (response to 1)
Posted by Roberto Mello on
Do you have your "ns_param IntranetEnabledP" set to 1? This is in parameters/your-service.tcl file
Collapse
3: Response to Intranet Setup (response to 1)
Posted by John Campbell on
Thank you!

I had this set to 1 in /var/opt/openacs/<servername>.ini and had not realized I had to set this parameter in /var/lib/aolserver/servers/defaultacs/parameters/defaultacs.tcl as well. I edited the file, restarted aolserver, and all is well.

Again, thanks.

Collapse
4: Response to Intranet Setup (response to 1)
Posted by David Walker on
Note that you use the .ini file or the .tcl.  I don't believe there is any way to use both.
Collapse
5: Response to Intranet Setup (response to 1)
Posted by Budi Wiyono on
Dear All,

I'm doing the same action, there is no error message at log file. But the appropriate intranet page
could not show up. How to trobleshoot this problem ?

[Tue Jun 12 18:49:59 2001] [notice] [client 127.0.0.1] [uri: /intranet/]
  Querying 'select case when ad_group_member_p(3, 11) = 't' then 1 else 0 end;'
[Tue Jun 12 18:49:59 2001] [notice] [client 127.0.0.1] [uri: /intranet/]
  sql(localhost:5432:my_openacs):  select case when ad_group_member_p(3, 11) = 't' then 1 el
se 0 end

Collapse
6: Response to Intranet Setup (response to 1)
Posted by Chris Hardy on
Did you make sure that the users are part of the intranet group (via /admin/ug).  ACS has this funky way of requiring you to be parts of a few diffrent groups to authenticate in /intranet .. I've never understood what they were smoking when that was first put together.. IF that does't work, yank up your logging and send a more verbose log.
Collapse
7: Response to Intranet Setup (response to 1)
Posted by Budi Wiyono on
I have set IntranetEnabledP=0 and Add several setup at http://127.0.0.1/admin/ug/group-type.tcl?group_type=intranet
With Intranet (number of groups defined: 7)

And then i add Group Members.
Now, it's working...

Thanks, for your help.