Forum OpenACS Development: Re: Exposing all of OpenACS/]po[ via REST

Collapse
Posted by Frank Bergmann on
Hi Dave,

> I am interested in the implementation of permissions

Then I would recommend you to download the file project-open-Update-3.4.0.8.0b.tgz from https://sourceforge.net/projects/project-open/files/, remove all duplicate packages and install the intranet-* packages. That should just work on top of a standard OpenACS 5.3 or 5.4 installation, at least we've successfully tested it a year ago.

Or just download one of the ]po[ installers from that Web site and install intranet-rest.

In about an hour I'll be available on Skype:frankxbergmann if you need help. I'd be happy to explain you about ]po[ "application permissions", which are based on the OpenACS permission system, but which contain application specific business logic.

Cheers!
Frank