For quite some time now we've had [string equal $string ""], and I've routinely rewritten empty_string_p code to use this as I've been working on packages.
The even newer "eq" (which came in 8.4, I think???) is even more welcome, more readable, easier to type, and more like a real computer language :)
So - go for it! Make those changes, sure.