Forum OpenACS Development: Re: Naviserver and libthread

Collapse
Posted by Gustaf Neumann on
Hi Dave,

libthread can be built with and without aolserver/naviserver support. With this support, some cmd names are called differently and the library can be called / initialized as a aolserver/naviserver module. The exactly same happens in AolServer and NaviServer.

Guess you picked a version without that support. When you build a new version, i would recommend to use tclibthread 2.7.0, which has a few memory leaks less. I guess it is the easiest to use the install-script from [1].

all the best
-gustaf neumann

[1] http://openacs.org/xowiki/naviserver-openacs