Forum OpenACS Development: OpenACS 5.9 Complaints about PostgreSQL 8.4

Request notifications

Hi!

Just seen this today. We need to run (a limited part of= OpenACS still on PG 8.4. Is there a way to disable the check? OpenACS 5.10 seems to go without it...

Cheers,
Frank

Collapse
Posted by Gustaf Neumann on
The postgres community has stopped all support for pg 8.4 in July 2014. Support for pg 9.0 stopped in Sept 2015. It is certainly not recommended to run systems on unmaintained database systems with security holes. We do not have the resources to test openacs on old versions of pg, and to program around bugs that were fixed many years ago.

The HEAD version of OpenACS is essentially OpenACS 5.8.*. The fact that it does not complain about pg 8.4 says nothing that it works with it. The head version is not a released version (and never was). Currently, all development happens in the oacs-5-9 branch. When active development stops in oacs-5-9, the version will be merged with HEAD. The version numbering of HEAD acs current release + 1 is needed for the apm management.

If some of your installations work with pg 8.4, then remove the check on your installations, but you have to do this on your own risk .... unless there is a volunteer who provides support for pg 8.4.

Collapse
Posted by Frank Bergmann on
Hi,

Thanks for the information on HEAD. Just FYI, the version number on HEAD already include 5.10.x.

So we'll need to patch OpenACS 5.9 to work with PostgreSQL 8.4, because we need to test with quite a lot of existing installations.

Thanks!!
Frank

Collapse
Posted by Gustaf Neumann on
The version number of on head is always one number higher than the version number of the release branch (as mentioned, needed for apm management).

The recommended action is certainly to upgrade pg8.4 to 9.*. this is typically just a pg-dump + pg-restore (since pg 9.0, there is pg_upgrade). Pg documentation [1] contains an example for using pg_upgrade from 8.4.

[1] http://www.postgresql.org/docs/9.2/static/pgupgrade.html