Forum OpenACS Q&A: Re: First steps when starting with xowf

Collapse
Posted by Claudio Pasolini on
I just completed a fresh installation of OpenACS 5.9 using the scripts found in "Install OpenACS with NaviServer from Scratch" and encountered some small problems.

The config-oacs-5-9.tcl has the parameter 'address' of nsssl module set to a non existent variable $address that should be set instead to $address_v4.

Trying to install xowf there was a dependency problem due to the installed version 5.9.1d4 of acs-tcl instead of 5.9.1d7 required by xotcl. I replaced acs-tcl with the version 5.9.1d8 checked out by cvs and the installation went well.

I made the installation on my ubuntu 16.04 LTS which has switched to systemd from upstart, but the installation script creates instead the /etc/init/oacs-5-9.conf.

Now on to xowf, but only after Italia vs Germania!

Collapse
Posted by Gustaf Neumann on
> config file with $address_v4:

this is fixed since may 20 in the navisever repo, but the tar file was released before that. The change will bin in the next naviserver release.

> installed version 5.9.1d4 of acs-tcl instead of 5.9.1d7 required by xotcl
the current version of acs-tcl is 5.9.1d8, xotcl-core requires 5.9.1d7, which should be fine..... so i guess, you get 5.9.1d4 via from apm. i have re-tagged acs-tcl, so the version from .apm should be sufficient.

> ubuntu switched ....
sigh. If i see correctly [1], ubuntu supports both upstart and systemd since 15.04, so one should probably try to install both files. i will look into this soon (but after todays game).

Germany did not win against Italy in the champions ship ever. In the games of the Euro, so far the Italian defense was one of the best, and the Italians are always capable to score a goal.... i am thrilled as well, but probably in no way at the same degree as a fan from italia...

[1] https://wiki.ubuntu.com/SystemdForUpstartUsers

Collapse
Posted by Gustaf Neumann on
the updated version of the install_ns script [1] produces now the upstart script and the systemd script for ubuntu versions ge 15.04.

[1] https://github.com/gustafn/install-ns/commit/6149891f2b0884f2c40f4b789c1695d8b59befa2