Forum OpenACS Development: Accessing TCL scripts under serverroot/www

Request notifications

Hi

I don't know whether this is an OpenACS or a Naviserver issue, so hopefully someone can enlighten me. On a legacy system of ours running on AOLserver and an old version of OpenACS, TCL scripts placed under ${serverroot}/www were accessible in the browser by visiting the corresponding URL e.g. ${serverroot}/www/brian.tcl was available at http://localhost:8100/brian.tcl
This was also true for the contents of www/resources, www/styles, www/images etc.

It seems that now under OpenACS 590 and Naviserver, in order to get the same result, I need to place the content under /packages/acs-subsite/www

Is there a setting that controls this, so that I can leave the code under ${serverroot}/www, or it is recommended that I move everything to /packages/acs-subsite/www?

thanks
Brian

Collapse
Posted by Antonio Pisano on
Hello Brain,

there is a chance something is being overlooked. This feature never changed in the years AFAIK and I have used it on a regular basis.

Just to be 101% sure, I have just putting a file called brian.adp into ${server_root}/www with some content and everything was fine. I am running latest OpenACS and naviserver 4.99.15.

Do you have special configs in place? ...Proxies?

Collapse
Posted by Brian Fenton on
Hi Antonio

thanks for replying. I don't have any special config, this is on a fresh install of the Windows build, that Maurizio has provided here http://www.spazioit.com/pages_en/sol_inf_en/windows-openacs_en/

The log says:
[29/Mar/2017:14:33:08][3656.110][-conn:openacs:2-] Error: return: failed to redirect '404': exceeded recursion limit of 3
[29/Mar/2017:15:11:45][3656.110][-conn:openacs:2-] Error: return: failed to redirect '404': exceeded recursion limit of 3
[29/Mar/2017:15:11:51][3656.110][-conn:openacs:2-] Error: return: failed to redirect '404': exceeded recursion limit of 3

Not sure why it's returning the 404.

thanks for the response.
Brian

Collapse
Posted by Maurizio Martignano on
This has been fixed as per my other post and it is available in the installer since 2 weeks or so.

Maurizio

Collapse
Posted by Brian Fenton on
Indeed it has been fixed! It's working now for me. Many thanks Maurizio for a great response.

Brian

Collapse
Posted by Maurizio Martignano on
Dear Brian,
Perhaps you need to make sure you have the following in your config:

ns_section "ns/server/${server}/fastpath"
ns_param serverdir ${homedir}
ns_param pagedir ${pageroot}

Hope it helps,
Maurizio

Collapse
Posted by Gustaf Neumann on
Brian, this was neither an OpenACS 5.9.* issue, nor a NaviServer issue, but a config file issue. The solution that Maurizio presented is exactly what is present in the recommended default settings shipped with the sample config file for NaviServer (see e.g. [1]).

Since it looks as if your config file was not derived from the sample-config-file, but rather from a legacy configuration, it might be usefule to check for more differences to avoid surprises.

all the best
-gn

[1] https://bitbucket.org/naviserver/naviserver/src/e045cbe91217a66729a065c98e9548ff4a025e06/openacs-config.tcl?at=naviserver-4.99.15&fileviewer=file-view-default

Collapse
Posted by Brian Fenton on
Gustaf, I'm really glad you mentioned that, as I just compared the latest version of the config.tcl with the version I've been using, and they are very different! My config was a modified version of the one included in Maurizio's installer about a month ago, but I hadn't taken Maurizio's latest changes.

thanks again
Brian