Forum OpenACS Q&A: Redirection to localhost

Request notifications

Collapse
Posted by Juan Carlos on
I installed Naviserver and OpenACS 5.9.1b3 in a remote linux server. However, I have a problem.

Whenever a do something like a login, it redirects me to my PC localhost, instead of the server IP

For example, if my IP is: xxx

Im in xxx:8000, but when I login, it redirects me to localhost:8000. What can I do?

Collapse
Posted by Gustaf Neumann on
Can it be, that you have not configured the SystemURL correctly? SystemURL is a Kernel parameter. To inspect/change it, browse to /acs-admin/ , in the line with "ACS Kernel" you see a link "parameters"; click there and look for the parameter "SystemURL"
Collapse
Posted by Juan Carlos on
Never mind, I figured it out. I had to change the variable "hostname" from localhost to the server IP in the config-5-91b3.tcl file.