Forum OpenACS Q&A: Daily forums notifications not working

Request notifications

Daily notifications on openacs.org forums are not working, at least
not for me.  Anybody know why?
Collapse
Posted by Jonathan Ellis on
additionally, when I "request notification" it first sends me all posts to the thread made before I turned on notify.
Collapse
Posted by Jamie Rasmussen on
I am not receiving daily notifications either.  Also, is it possible to modify the frequency of a notification without unsubscribing and resubscribing to it?
Collapse
Posted by Paul Doerwald on

Good -- I'm not the only one who's not receiving daily notifications.

I added a note to the bugtracker about this issue:

http://openacs.org/bugtracker/openacs.org/bug?bug%5fnumber=48

Collapse
Posted by Dave Bauer on
Did anyone receive daily notifications?

The last time the daily scheduled proc was run was Wed, 06 Nov 2002 02:00:24 GMT and it is scheduled next for Thu, 07 Nov 2002 02:00:28 GMT.

Collapse
Posted by Jamie Rasmussen on
Did anyone receive daily notifications?
The last time the daily scheduled proc was run was Wed, 06 Nov 2002 02:00:24 GMT and it is scheduled next for Thu, 07 Nov 2002 02:00:28 GMT.

I'm afraid I didn't get daily notifications yesterday or today.

Collapse
Posted by Brian Fenton on
This is still (not) happening. I noticed the note Paul added in Bugtracker is still unassigned. Has it slipped through un-noticed or are people just too busy? I'd like to help, but don't really know what I could do. Can any of the people mentioned on the Site Credits page look into this please?

thanks!

Collapse
Posted by Jeff Davis on
Dave Bauer has looked at it (and I think he thought it was
fixed).  Dave knows the details but the short answer is that
there were (and maybe are) two problems: The instant sweeper
was deleting all notification entries (even those for daily
and weekly notifications).  The second problem is that if the
server gets restarted the daily and weekly sweeps won't happen
for another day (or week).  That means to get a notification on a weekly sweep you have to have the server running for a week.

Anyway, they are not entirely trivial to fix but that's my understanding of the problem.

Collapse
Posted by Brian Fenton on
Thanks Jeff. Dave (Bauer), if I can help I will. Just let me know what you need.
Collapse
Posted by Andrew Piskorski on
It seems that instant forum notifications have some problems too. Today, I read the "Installing Oracle 8.1.7 on Redhat 8.0" thread and clicked to request instant notifications on it.

Imagine my surprise to check my email, and find a separate email for what appeared to be every single post that's ever been made to that thread. Oh yeah, and in no particular order, and with all the dates set to today with no information at all as to when the post was actulaly made.

I haven't had time to try and track this bug down yet myself, but FYI...

Ah, another bug: On the /notifications/manage page, the "Item" links, which which are either the forum names or the subjects of the forums posts, don't work at all. Clicking on them takes you nowhere. For example, this "Daily forums notifications not working" link.