Forum OpenACS Q&A: Daily Forums Notifications gone again?

Request notifications

Collapse
Posted by Brian Fenton on
I didn't get a daily forums mail this morning (and maybe yesterday morning either? Can't remember now.) Has it gone down again?
Collapse
Posted by Emmanuelle Raffenne on
It seems that instant notification doesn't work either since yesterday afternoon (gmt+1).
Collapse
Posted by Jeff Davis on
The forums notifications are going out just fine. We did change the return-path and the From: header so that some more aggressive spam filters may just nuke the mail (as Mat Kovach pointed out we could make the mails a lot more list like with List- and In-Reply-To headers etc). We also have the problem that openacs.org's IP address does not reverse to openacs.org which also makes it look more like spam than it should). In any case, depending on how you are filtering spam you might look if you need a whitelist entry for openacs.org or just come to terms with getting less mail :)
Collapse
Posted by Jamie Rasmussen on
I'm not getting any notifications either.  I wonder, how widespread is this problem?  Could something other than a spam filter be dropping the message?
Collapse
Posted by Jamie Rasmussen on
Strange - I just received an instant notification on my previous message (which I requested), but I haven't gotten a daily notification in a few days.
Collapse
Posted by Jeff Davis on
There was a bug introduced for batched notifications (the code presumed there would always be a creation_user for a notification but for batched notifies there is not one). Anyway, hopefully it's fixed now and batched notifies will start working again.
Collapse
Posted by Emmanuelle Raffenne on
Jeff,

So maybe the problem is another. Here is the full story: I was receiving notifications normally, even after the modifications you mention. I don't have any filter for spam :/. On friday afternoon/evening, I stop receive notifications for a while then I thought it was a problem with the notifications system because of those modifications; it was a problem of my ISP mail server but I didn't know yet. I unsubscribed and subscribe again. Since then, I don't receive notifications anymore.

Collapse
Posted by Emmanuelle Raffenne on
Jeff,

Then ignore my last message, we post at the same time. Thank you.

Collapse
Posted by Brian Fenton on
Cool! They're back again. While we're on the subject, there's just one more thing: the batched mail seems to have the postings sorted in (to my eye) a fairly random order. They used  be sorted by date of posting (with oldest at the top of the mail). It would be great if they could be sorted that way again - it made reading the digest mail much easier.

Thanks for the efficiency!