Forum OpenACS Q&A: Re: aolserver-4.5
aolserver 4.5 requires OpenACS 5.2
The page, you are pointing to, is not mentioning aolserver 4.5.
I didn't know AOLServer 4.5 was incompatible with OpenACS 5.0.4 and earlier. When upgrading I had an issue with the content type for text/html. This hack/patch enabled me to upgrade to OpenACS 5.2.3: