Forum OpenACS Q&A: aolserver-4.5
Unless you are a developer needing the newest features from aolserver 4.5, i would recommend to stick with aolserver 4.0.10.
I have OpenACS 5.0.4 working with AOLServer 4.5. I would have opted for 4.0.10 if I was aware of problems.
aolserver 4.5 requires OpenACS 5.2
The page, you are pointing to, is not mentioning aolserver 4.5.
I didn't know AOLServer 4.5 was incompatible with OpenACS 5.0.4 and earlier. When upgrading I had an issue with the content type for text/html. This hack/patch enabled me to upgrade to OpenACS 5.2.3:
I am working on an install package of dotlrn for gentoo, called an ebuild. I just wanted to get the versions correct.
The current ebuild for aolserver is broke. If aolserver-4.5.0 worked with the released versions of oacs-5.2, I would've built a new ebuld for that ver. Since it does not, I will see about fixing the existing ebuild.