Home
The Toolkit for Online Communities
17479 Community Members, 0 members online, 1925 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : aolserver-4.5

Forum OpenACS Q&A: aolserver-4.5

Icon of envelope Request notifications

Collapse
Posted by Al Guyer on
does oacs-5.2 work with aolserver-4.5?
Collapse
2: Re: aolserver-4.5 (response to 1)
Posted by Gustaf Neumann on
one has to be more precise here. The released versions (tar balls) including oacs 5.2.3 do not work unchanged with aolserver 4-5. The newest versions from cvs work (e.g. the newest version from the oacs-5-2 branch, or cvs head).

Unless you are a developer needing the newest features from aolserver 4.5, i would recommend to stick with aolserver 4.0.10.

Collapse
4: Re: aolserver-4.5 (response to 2)
Posted by Guan Yang on
Is there any overview of the changes that were made to support AOLserver 4.5, in case I want to modify an existing installation?
Collapse
5: Re: aolserver-4.5 (response to 4)
Posted by Michael Bluett on
Could we update the Prerequisites page to highlight the fact that AOLServer4.5 doesn't work?

http://openacs.org/doc/current/individual-programs.html

I have OpenACS 5.0.4 working with AOLServer 4.5. I would have opted for 4.0.10 if I was aware of problems.

Collapse
6: Re: aolserver-4.5 (response to 5)
Posted by Gustaf Neumann on
The compatibility matrix is your friend
http://openacs.org/xowiki/openacs-compatibility-matrix

aolserver 4.5 requires OpenACS 5.2

The page, you are pointing to, is not mentioning aolserver 4.5.

Collapse
7: Re: aolserver-4.5 (response to 6)
Posted by Michael Bluett on
Or more precisely, the xowiki compatibility matrix is your friend :) Thanks, AOLServer 4.5 is working well for me at the moment.

I didn't know AOLServer 4.5 was incompatible with OpenACS 5.0.4 and earlier. When upgrading I had an issue with the content type for text/html. This hack/patch enabled me to upgrade to OpenACS 5.2.3:
http://www.mail-archive.com/aolserver@listserv.aol.com/msg10006.html

Collapse
3: Re: aolserver-4.5 (response to 1)
Posted by Al Guyer on
ah-h, yes, I see. Thank you for the advice, I will stick with
aolserver 4.0.10.

I am working on an install package of dotlrn for gentoo, called an ebuild. I just wanted to get the versions correct.
The current ebuild for aolserver is broke. If aolserver-4.5.0 worked with the released versions of oacs-5.2, I would've built a new ebuld for that ver. Since it does not, I will see about fixing the existing ebuild.

Thanks again,

-al