Home
The Toolkit for Online Communities
17225 Community Members, 0 members online, 1918 visitors today
Log In Register
OpenACS Home : Forums : OpenACS Q&A : Problems installing modules to AOL Server 4.0.9b in Mac OS X 10.3.5

Forum OpenACS Q&A: Problems installing modules to AOL Server 4.0.9b in Mac OS X 10.3.5

Icon of envelope Request notifications

Hi guys,

I've been trying to install the OpenACS toolkit but I run into a bunch of problems while adding the modules needed to AOLServer. I've already Postgres 7.4.3, tcl 8.4.7, AOLServer 4.0.9b and tdom 0.8

I downloaded from sourceforge.net the following packages:
nscache 0.6
nspostgres-4.0
nssha1-0

This is where aolserver is installed: /usr/local/aolserver
This is where postgres is installed: /usr/local/pgsql

I don't want to trouble you with such a long post, so I'll try the first error I get.

When I try to install nscache I get the following messages:

GUAMAC01:/usr/local/src/aolserver-4.0.9b/nscache-0.6 Jose$ sudo ./configure
Password:
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for a BSD compatible install... /usr/bin/install -c
checking whether make sets ${MAKE}... (cached) yes
checking for msgfmt... msgfmt
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for X... libraries /usr/X11R6/lib, headers
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking whether byte ordering is bigendian... yes
checking for getopt_long... yes
checking for working fnmatch... yes
checking for gettext in -lc... no
checking for gettext in -lintl... no
checking for dbopen in -lc... yes
checking for db1/db.h... no
checking for db_185.h... no
checking for db.h... yes
checking for regex.h... yes
checking for POSIX regcomp()... yes
checking for gtk-config... no
checking for gtk-config-2.0... (cached) no
configure: error: Unable to find "gtk-config" program

and when a type make install this is what I get:

GUAMAC01:/usr/local/src/aolserver-4.0.9b/nscache-0.6 Jose$ make install
make: Nothing to be done for `install'.

what can the problem be?

Thanks in advance!

Jose Lucero

I think you have an old version of nscache.  Should be using nscache 1.6 or newer.
Hi Nick thanks for your help. I'll try to find a newer version of nscache.

I'm new at this, thanks a lot!

Jose

Hi guys, sorry to bother you with my silly questions.

Now I'm trying to install nspostgres and I get this message:

UD3-25:/usr/local/src/aolserver-4.0.9b/nspostgres-4.0 Jose$ sudo make install
**
** POSTGRES variable not set.
** nspostgres.so will not be built.
**
** Usage: make POSTGRES=/path/to/postgresql
**        make POSTGRES=LSB
**
** Usage: make install POSTGRES=/path/to/postgresql INST=/path/to/aolserver
**        make install POSTGRES=LSB INST=/path/to/aolserver
**
** OpenACS users should also set ACS=1
**
** AOLserver 3.x users should set AS3=1
**
make: *** [check-env] Error 1

What's the problem here?

Thanks in advance,

Jose Lucero

Hello Jose

You have posted the answer to your own question in the error message:

** Usage: make install POSTGRES=/path/to/postgresql INST=/path/to/aolserver
**        make install POSTGRES=LSB INST=/path/to/aolserver

Hi Bruno,

I messed up. this is what I intended to post.

Thanks for your help!

I get this error when I do this: make install POSTGRES=/usr/local/pgsql/ INST=/usr/local/aolserver/

definition of _TclpObjListVolumes
/Library/Frameworks/Tcl.framework/Tcl(tclUnixFCmd.o) definition of
_TclpObjListVolumes
ld: Undefined symbols:
_Ns_Db0or1Row
_Ns_Db1Row
_Ns_DbDML
_Ns_DbDriverName
_Ns_DbExec
_Ns_DbGetRow
_Ns_DbRegisterDriver
_Ns_DbSelect
_Ns_DbSetException
_Ns_TclDbGetHandle
_SSL_pending
_BIO_free
_BIO_new_mem_buf
_DH_check
_DH_generate_parameters
_DH_size
_ERR_get_error
_ERR_reason_error_string
_EVP_PKEY_free
_PEM_read_DHparams
_PEM_read_PrivateKey
_PEM_read_X509
_PEM_read_bio_DHparams
_SSL_CTX_ctrl
_SSL_CTX_free
_SSL_CTX_load_verify_locations
_SSL_CTX_new
_SSL_CTX_set_tmp_dh_callback
_SSL_CTX_set_verify
_SSL_CTX_set_verify_depth
_SSL_connect
_SSL_free
_SSL_get_error
_SSL_get_ex_data
_SSL_get_peer_certificate
_SSL_library_init
_SSL_load_error_strings
_SSL_new
_SSL_read
_SSL_set_ex_data
_SSL_set_fd
_SSL_shutdown
_SSL_write
_TLSv1_method
_X509_NAME_get_text_by_NID
_X509_NAME_oneline
_X509_check_private_key
_X509_free
_X509_get_subject_name
make: *** [nspostgres.so] Error 1

Hello again,

From this:

ld: Undefined symbols:
_Ns_Db0or1Row
_Ns_Db1Row
_Ns_DbDML
[ ... ]
I would suspect that you are not linking against where AOLServer's libraries are installed, but I am not 100% sure.

Are you sure AOLServer is installed in /usr/local/aolserver?

Hi again,

I found this thread right here on this forum that deals with the same problem I had with the nspostgres module. The error I get is because my postgres installation was done with SSL. So an -ssl tag must be added to the MODLIBS line.

That didn't fix the problem so I added -lcrypo to the MODLIBS line also.

Here's the link to the other thread: http://openacs.org/forums/message-view?message_id=118559

But now the problem comes from aolsever when I try to start it. I get the following error:

UD2-25:/web/openacs/etc Jose$ /usr/local/aolserver/bin/nsd -ft /web/openacs/etc/config.tcl
[24/Oct/2004:08:01:28][563.2684396012][-main-] Error: dns: getaddrinfo failed: No address associated with nodename

How can I fix this?

Thanks for all your help!

Here is another problem that I'm getting with aolserver

UD3-25:/usr/local/aolserver Jose$ ./bin/nsd -t sample-config.tcl -u nobody -g web
[23/Oct/2004:19:01:24][3924.2684396012][-main-] Error: dns: getaddrinfo failed: No address associated with nodename
UD3-25:/usr/local/aolserver Jose$ [23/Oct/2004:19:01:24][3925.2684396012][-main-] Warning: config.tcl: nsssl not loaded -- key/cert files do not exist.
[23/Oct/2004:19:01:24][3925.2684396012][-main-] Notice: encoding: loaded: iso8859-1

Where can I fix this?

Thanks in advance!

Hi Bruno,

I'm positive aolserver is installed in /usr/local/aolserver

What else can the problem be?

Thanks for your help!

Jose, check the value of hostname in the config.tcl file.

If you are using "localhost" you might want to try "local" for OS X.

I'm installing an openacs (development) system on OS X here. Although "local" is accepted, the browser couldn't see the aolserver page. I had to access via the external ip address, which I found by using 'ifconfig'.

hope this helps

Torben

Hi Torben,

I changed the values for hostname and address for 127.0.0.1 as you said, and I don't get the dns error anymore. But I'm still getting this message at the end:

GUAMAC01:/web/openacs Jose$ /usr/local/aolserver/bin/nsd -ft /web/openacs/etc/config.tcl
...
[25/Oct/2004:08:51:25][420.2684396012][-main-] Notice: Executing initialization code blocks...
alloc: invalid block: 0x294140: ef ef 0

Abort trap

What can this be?

Thanks in advance!

For a development box, you can set both the address and hostname to 127.0.0.1. Somewhere I read that OS X drops the ethernet device if there's no physical RJ45 cable and the Airport card (on a PB) can't find a network, and this avoids that problem. It works for me anyway even though why it does dips below my Tech Knowledge Event Horizon. ;-)

But there must be more than one way to do it, since Vinod uses 0.0.0.0 for the address and localhost for hostname -- see this thread.

Yeah.  I have some more digging to do on this machine, because 127.0.0.1 didn't work here either, just the external ip address works. =\
In ns_section ns/threads, did you set the stack size to be an even multiple of 4096? For example:

ns_param stacksize 499712

This avoids a "pthread_stacksize error" on launch, and may be related to your error as well, since it looks like you're running into some low-level memory issue.

Hi Stan,

I changed the stack size to the number you sugested and I'm still getting the error.

[25/Oct/2004:15:34:30][3927.2684396012][-main-] Notice: Executing initialization code blocks...
alloc: invalid block: 0xfa140: ef ef 0

Abort trap

What else could it be?

Thanks in advance!

Jose, what I always do in such situations is google the error. A quick&dirty look finds this posting which suggests that you may not have tcl compiled with threads enabled on your machine.

Are you trying to use the tcl installed by OS X? I would install tcl directly if you haven't, and make sure that you compile the other stuff (aolserver, pg) with that tcl. I think that's what I did, but it's over a year ago and I've long since martyred those brain cells. ;-)

Hi guys,

I finally succeded in getting everything to run right. I had to go back to aolserver 4.0.8 as couln't manage to start 4.0.9b.

In the end, I used the following software for my installation on my PowerBook G4 running Mac OS X 10.3.5:

tcl 8.4.7
readline 5.0
postgres 7.4.5
aolserver 4.0.8
nscache 1.5
nssha 1
nsrewrite
nspostgres 4.0
tdom 7.8

Thanks to all of you who helped me.

Best regards,

Jose Lucero