Forum OpenACS Q&A: Re: Problems installing modules to AOL Server 4.0.9b in Mac OS X 10.3.5

Jose, what I always do in such situations is google the error. A quick&dirty look finds this posting which suggests that you may not have tcl compiled with threads enabled on your machine.

Are you trying to use the tcl installed by OS X? I would install tcl directly if you haven't, and make sure that you compile the other stuff (aolserver, pg) with that tcl. I think that's what I did, but it's over a year ago and I've long since martyred those brain cells. ;-)

Hi guys,

I finally succeded in getting everything to run right. I had to go back to aolserver 4.0.8 as couln't manage to start 4.0.9b.

In the end, I used the following software for my installation on my PowerBook G4 running Mac OS X 10.3.5:

tcl 8.4.7
readline 5.0
postgres 7.4.5
aolserver 4.0.8
nscache 1.5
nssha 1
nspostgres 4.0
tdom 7.8

Thanks to all of you who helped me.

Best regards,

Jose Lucero