Forum OpenACS Q&A: Re: Help with openacs installing

Collapse
Posted by Gustaf Neumann on
The error tells you that the needed include file from postgres (a build-dependency) is missing. Have you issued "apt-get build-dep aolserver4-nspostgres" before running "dpkg-buildpackage" in aolserver4-nspostgres-4.5?
Collapse
Posted by Lester Temmink on
root@ubuntu:~# apt-get build-dep aolserver4-nspostgres
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
Collapse
Posted by Gustaf Neumann on
Strange, that i did not see the problem on the two system i tried. Get the following package. that should include the missing .h file

apt-get install libpq-dev
Collapse
Posted by Lester Temmink on
No.. already got this package.

root@ubuntu:/# apt-get install libpq-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libpq-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
root@ubuntu:/#

Collapse
Posted by Gustaf Neumann on
ok. now is see, what the problem is: you missed the space before "-Wl,--no-as-needed" when you updated Makefile.debian
Collapse
Posted by Lester Temmink on
Tnx, that worked out for me:

But then.. next problem..

Thank you for installing the Open Architecture Community System (OpenACS), a suite of fully-integrated enterprise-class solutions for collaborative commerce. This is the OpenACS Installer which performs all the steps necessary to get the OpenACS Community System running on your server.
Please read the Release Notes before proceeding to better understand what is contained in this release.

Your PostgreSQL driver is correctly installed and configured.

The OpenACS data model is already installed. Click Next to scan the available packages

When i click next, i get nothing.

Webpage says, no data received.

Collapse
Posted by Lester Temmink on
error.log

[15/Aug/2013:16:35:45][21171.18446744073082287872][-nssock:driver-] Notice: starting
[15/Aug/2013:16:35:45][21171.18446744073082287872][-nssock:driver-] Notice: nssock: listening on 10.10.10.17:8000
[15/Aug/2013:16:35:47][21171.18446744073090692864][-default:1-] Warning: tclfilter: install_handler return invalid result:
[15/Aug/2013:16:35:48][21171.18446744073099097856][-default:3-] Error: Unable to source /usr/share/openacs/packages/acs-bootstrap-installer/installer/packages-install.$
[15/Aug/2013:16:35:49][21171.18446744073103300352][-default:4-] Error: Unable to source /usr/share/openacs/packages/acs-bootstrap-installer/installer/packages-install.$
[15/Aug/2013:16:35:51][21171.18446744073086490368][-default:0-] Error: Unable to source /usr/share/openacs/packages/acs-bootstrap-installer/installer/packages-install.$
[15/Aug/2013:16:35:55][21171.18446744073321154304][-main-] Notice: nsmain: AOLserver/4.5.1 stopping
[15/Aug/2013:16:35:55][21171.18446744073321154304][-main-] Notice: driver: stopping: nssock
[15/Aug/2013:16:35:55][21171.18446744073321154304][-main-] Notice: sched: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073090692864][-default:1-] Notice: exiting: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073271260928][-sched-] Notice: sched: shutdown started
[15/Aug/2013:16:35:55][21171.18446744073271260928][-sched-] Notice: sched: shutdown complete
[15/Aug/2013:16:35:55][21171.18446744073094895360][-default:2-] Notice: exiting: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073099097856][-default:3-] Notice: exiting: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073321154304][-main-] Notice: driver: stopped: nssock
[15/Aug/2013:16:35:55][21171.18446744073082287872][-nssock:driver-] Notice: exiting
[15/Aug/2013:16:35:55][21171.18446744073086490368][-default:0-] Notice: exiting: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073103300352][-default:4-] Notice: exiting: shutdown pending
[15/Aug/2013:16:35:55][21171.18446744073082287872][-shutdown-] Notice: nslog: closing '/usr/share/openacs/log/openacs.log'
[15/Aug/2013:16:35:55][21171.18446744073321154304][-main-] Notice: nsmain: AOLserver/4.5.1 exiting

Collapse
Posted by Gustaf Neumann on
sigh. The Debian/Ubuntu packages for OpenACS are in a worse state than i thought:

- There are the two bugs with the compiler flags fixed by the steps above; but fixing these is apparently not enough.

- OpenACS as packaged by the Debian packages is not compatible with PostgreSQL 9.*. Ubuntu 12.04 ships per default with PostgreSQL 9.1. Sooner or later, one runs either into the problem of Iuri Sampaio (syntax error [1]) or the problem of Chris Edwards (unrecognized configuration parameter "regex_flavor", [2]). The only option is to use PostgreSQL 8.4 instead with this release. But downgrading is not enough either.

- The newer aolserver as shipped with Ubuntu is apparently more picky about a incorrect return value from a filter (tclfilter: install_handler return invalid result; see above). This bug is fixed as well in the head version of OpenACS. This problem can be fixed by a two line modification in the OpenACS tree.

The OpenACS packages for debian require a new release. Dealing with the brokenness is already more work than installing from scratch. The whole thing happened, as a working verision of OpenACS was kept stable in the distribution, but the components around it changed (C-compiler flags, PostgreSQL, Aolserver). Hope, that the packager of the Debian OpenACS packages read this and can push our a working verison.

Incentivated by this malaise, i have just now put together two scripts that let you install the newest version of OpenACS on a wider range of systems; this version e.g. compatible with PostgreSQL 9.*. See: http://openacs.org/xowiki/naviserver-openacs

This should let you install OpenACS on your system.

Hope this helps finally
-gustaf neumann

[1] http://openacs.org/forums/message-view?message_id=4048828
[2] http://openacs.org/forums/message-view?message_id=4051830

Collapse
Posted by Lester Temmink on
Well, not very lucky with that though:

bash install-ns.sh
bash install-ns.sh build

checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

So.. fresh install ubuntu 12.04.
On what OS is OpenACS running fine? So I can use that one?

Collapse
Posted by Gustaf Neumann on
The scripts checked the current OS compatibility with "/etc/debian-version" instead of "/etc/debian_version". sigh, i need better glasses. Please re-fetch the scripts and run it again.

Just now, i have installed OpenACS with the updated scripts on 2 fresh VMs, one with Ubuntu 12.0 and one with Ubuntu 13.04, both went through fine.

The question is actually not, on which OS OpenACS is running fine, but on which OS is it the easiest to install. We are running on our large production system under RHEL 6.4, the OpenACS installation on alice.wu.ac.at:8000 under Fedora 18, on openacs.org on Ubuntu 10.04, and on my notebook under Mac OS X 10.8. On all these OSes, OpenACS runs fine.

From my experiences with the VMs, i would recommend to use Ubuntu 13.04 instead of 12.04, since at least under my host OS, 12.04 made much troubles (no graphics support after installing from the iso, one has to upgrade from the rescue menu, then problems with the shared folders and "guest additions" under vbox) furthermore, the upgrades from apt-get are much faster in 13.04.

Collapse
Posted by Héctor Romojaro on
Dear Gustaf and all,

I'm no longer using OpenACS at work, but I still maintain both openacs and dotlrn debian packages in my spare time, and your post hurted my feelings :)

Not responsible for the aolserver packages though, but i guess their maintainer reads this forum.

With that said, let see all the issues in detail:

- PG 9.1: The openacs package (5.7.0) is currently using "standard_conforming_strings = off" as a compatibility option in the openacs database to avoid the errors. It seemed to work fine, and I asked if there was any other change to do in the OCT list. I was told that using a more recent version of nspostgres would make the "standard_conforming_strings = off" unnecesary. IIRC, the nspostgres maintainer was asked about updating it (i think it was Stefan who asked him to), but, as it was never updated, i kept that option hoping it would be enough.

- Changes in head to support newer aolserver: I could include a patch in the package that modifies the openacs tarball and fix this but, at this point, i think the best solution is to package a new version of openacs (5.8) with proper pg9.x and aolserver compatibility.

Is there any estimation of when 5.8 will be *officially* out, with its static tarball in the download page? If the release is no near though, i'll go with the patch, but i think this is a way better solution.

However, we'll have to deal with the nspostgres issues. I'll try to contact its maintainer to see if he's willing to update it.

P.S: not the place to say it, but dotlrn packages has those and worse problems too. 2.5.0 is extremely old and, if no release is made soon, i fear for its continuity in the debian archive.

Kind regards,
Héctor Romojaro

Collapse
Posted by Jim Lynch on
Hector and the group,

openacs-5.7 doesn't like pg-9, it does like pg-8.3 and maybe also 8.4.

openacs-HEAD (which some are calling 5.8) does like pg-9.2. It's not released yet, and so far I can find no information on who's working on it, when it will be released or what its status is.

For your (and other's) convenience, I adjusted the build system of nspostgres so that you can supply the location of pg_config, and have the build use pg_config to find things, which I recommend. I was working with Dossy when I added this feature to the makefile. I carefully documented the build options in the makefile; please read for more info.

One place you can find pg_config is in the debian package postgresql-server-dev-x.y (where x.y is the postgres version), and then you will find pg_config in /usr/lib/postgresql/x.y/bin/pg_config.

I tend to recommend building the whole stack as you have and keep much more control: upgrading debian packages then have no chance of touching your web stack, and the prefix of just about everything can be set to the same place. I do like how the pg packages install and where it puts things, so it's been awhile since I last built pg.

Anyway, hope this helps and I'll probably contribute more to this thread later.

I thought I heard at one of the dotlrn meetings that the last dotlrn was about to be released, as MIT Sloan stopped using it. (can someone confirm this?)

-Jim

Collapse
Posted by Jim Lynch on
One more thing... Victor Guerra had been working on moving openacs to git; any progress here? (in the past, I would occasionally ask him to run a cvs->git import script he wrote.)

-Jim

Collapse
Posted by Lester Temmink on
Got it working on ubuntu 13.04 :) Tnx for all the support.
Collapse
Posted by Lester Temmink on
Im going to use OpenACS to monitor and configure modems, Which application is the best to do this?
Collapse
Posted by Gustaf Neumann on
Lester,

after this endless thread (thanks for keeping up) i got the impression that you got the wrong OpenACS (the community system/web framework, as in http://en.wikipedia.org/wiki/OpenACS), but you are interested in http://sourceforge.net/projects/openacs/ (an implementation of http://en.wikipedia.org/wiki/TR-069, a remote management and configuration server for network devices; ACS stands here for "auto configuration server"). Anyhow, many thanks, you made clear to me, how bad the state of the ubuntu/debian packages really is.

Jim, the scripts i added (see above) install OpenACS on Ubuntu/Fedora systems for PG 9.+ from scratch, including the updated postgres driver, tcl, tdom, xotcl, ..., using OpenACS, xo* and dotlrn from cvs and xowf from git, but using a packaged postgres version (on Ubuntu 9.1, on Fedora 9.2). We (mostly Victor and me) work in Vienna towards a 5.8 release, there is already a oacs-5-8 branch of OpenACS in CVS. Everybody is welcome to test it, and to contribute to the release.

As always, the release of the openacs-core packages comes first, then application packages. It is not clear yet, when and in which form a dotlrn release will come out (most dotlrn applications are substantially tailored sites, developed by busy people with not-so-much benefit from a new release).

Hope this helps
-gustaf neumann