Forum OpenACS Q&A: Re: First steps when starting with xowf

Collapse
Posted by Gustaf Neumann on
Dear Claudio,

In general, i would recommend not using HEAD, but using OpenACS 5.9.* and either install xowf via "install from repository" or from the CVS oacs-5-9 branch.

The error message above indicates, that the form-field type "workflow_definition" is not defined on your system. This formfield type is defined by the xowf package. Since you mentioned, that you installed xowf, i would assume that something went wrong during installation/startup.

What are the verison numbers on your system? The easiest is to check with /xotcl/version-numbers

-g

Collapse
Posted by Claudio Pasolini on
Dear Gustaf,

thank you very much for the qwick answer. Here is the version numbers:

Version Numbers of XOTcl and Related Packages

Database: PostgreSQL 9.5.3 on x86_64-pc-linux-gnu, compiled by gcc (Ubuntu 5.3.1-14ubuntu2) 5.3.1 20160413, 64-bit
Server: 4.99.11 (NaviServer)
Tcl: 8.5.19
XOTcl: 2.0.0
Tdom: 0.8.3
libthread: /usr/local/ns/lib/thread2.7.2/libthread2.7.2.so
Tcllib: /usr/local/ns/lib/tcllib1.18
acs-kernel: 2013-09-08, 5.10.0d1
xotcl-core: 2015-02-11, 0.138
xowiki: 2015-05-03, 5.9.0d3
xowf: 2011-05-16, 0.35

Apparently the installation (via repository) went well, but now looking at the error log (I should have done before posting) I found several warnings and one error:

^[[0;32m[29/Jun/2016:09:24:26][1981.7f030fefe700][-conn:oacs-HEAD:1-] ^[[0m^[[1;31mError: Error sourcing /var/lib/ns/oacs-HEAD/packages/xowf/tcl/xowf-form-field-procs.\
tcl:
wrong # args: should be "extend_slot arg" during '::xowiki::formfield::workflow_definition.extend_slot'
::xotcl::Class ::xotcl::Class->create
invoked from within
"::xotcl::Class create workflow_definition -superclass textarea -parameter {
{rows 20}
{cols 80}
{dpi 120}
} -extend_slot validator workf..."
("uplevel" body line 1)
invoked from within
"uplevel [list [self] create {*}$args]"
(procedure "unknown" line 3)
::xotcl::Class ::xotcl::Class->unknown
invoked from within
"Class workflow_definition -superclass textarea -parameter {
{rows 20}
{cols 80}
{dpi 120}
} -extend_slot validator workflow"
(in namespace eval "::xowiki::formfield" script line 8)
invoked from within
"namespace eval ::xowiki::formfield {
###########################################################
#
# ::xowiki::formfield::workflow_definition
..."
(file "/var/lib/ns/oacs-HEAD/packages/xowf/tcl/xowf-form-field-procs.tcl" line 10)

I'm just experimenting and so I could could simply restart with OpenACS 5.9.

Collapse
Posted by Gustaf Neumann on
it looks like the version of xowiki and xowf in HEAD are not aligned. going to 5.9 is the best.
Collapse
Posted by Claudio Pasolini on
I just completed a fresh installation of OpenACS 5.9 using the scripts found in "Install OpenACS with NaviServer from Scratch" and encountered some small problems.

The config-oacs-5-9.tcl has the parameter 'address' of nsssl module set to a non existent variable $address that should be set instead to $address_v4.

Trying to install xowf there was a dependency problem due to the installed version 5.9.1d4 of acs-tcl instead of 5.9.1d7 required by xotcl. I replaced acs-tcl with the version 5.9.1d8 checked out by cvs and the installation went well.

I made the installation on my ubuntu 16.04 LTS which has switched to systemd from upstart, but the installation script creates instead the /etc/init/oacs-5-9.conf.

Now on to xowf, but only after Italia vs Germania!

Collapse
Posted by Gustaf Neumann on
> config file with $address_v4:

this is fixed since may 20 in the navisever repo, but the tar file was released before that. The change will bin in the next naviserver release.

> installed version 5.9.1d4 of acs-tcl instead of 5.9.1d7 required by xotcl
the current version of acs-tcl is 5.9.1d8, xotcl-core requires 5.9.1d7, which should be fine..... so i guess, you get 5.9.1d4 via from apm. i have re-tagged acs-tcl, so the version from .apm should be sufficient.

> ubuntu switched ....
sigh. If i see correctly [1], ubuntu supports both upstart and systemd since 15.04, so one should probably try to install both files. i will look into this soon (but after todays game).

Germany did not win against Italy in the champions ship ever. In the games of the Euro, so far the Italian defense was one of the best, and the Italians are always capable to score a goal.... i am thrilled as well, but probably in no way at the same degree as a fan from italia...

[1] https://wiki.ubuntu.com/SystemdForUpstartUsers

Collapse
Posted by Gustaf Neumann on
the updated version of the install_ns script [1] produces now the upstart script and the systemd script for ubuntu versions ge 15.04.

[1] https://github.com/gustafn/install-ns/commit/6149891f2b0884f2c40f4b789c1695d8b59befa2