Forum OpenACS Q&A: Re: Upgrading a heavily modified site

Posted by Eric Wolfram on
Thanks Joel for posting those 4.5 --> 4.6 docs, they gave me enough confidence to try. Here are some examples of the issues I had, which will go to show you what type of bonehead you're up against when trying to make perfect docs. Maybe this journal of my attempt will help someone...

First I want to back up. I'm following the docs at:

I got stuck right away.

1. Postgresql backup

I had to login as user "postgres" on my machine, not nsadmin. We actually do have a user called "nsadmin" for the web server, so I was confused by those docs because I didn't notice the key at the top -- where nsadmin is defined as "any user" -- so thought you wanted me to log in as that specific user...of course, the database didn't let do anything as that user. When I loged in as the user for the database I was able to run the commnads.

Still, for the pg_dump, I had to go to /user/local/pgsql/bin, where the program pg_dump was, and then I had to put a ./ in front of the pg_dump command to force the path. I guess my paths for that postgres user doesn't point to that bin. It also didn't point to . That is, when I did echo $PATH I didn't see those paths...I don't know how to fix that...

2. File Tree with CVS --

* Running the cvs commit as nsadmin got the following error -- this is because nsadmin never change files or because something in the /CVS directory needs chmod/chgrp.

[nsadmin@rhumba new]$ cvs commit -m "last minute commits before upgrade to 4.6.3"
cvs [commit aborted]: cannot open CVS/Entries.Log: Permission denied
[nsadmin@rhumba new]$ [nsadmin@rhumba new]$

So I logged in as ewolfram and tried the CVS commit and got this:

cvs commit: Examining bin
cvs commit: Examining content-repository-content-files
cvs commit: Examining log
cvs commit: in directory log:
cvs [commit aborted]: there is no version here; do 'cvs checkout' first

I got concerned about the "aborted" in the output -- even though the output in the docs is snipped. CVS is choking on the log. I tried to check out log/  -- didn't work...

[ewolfram@rhumba new]$ cvs checkout log/
cvs checkout: cannot find module `log' - ignored

So I moved the log directory into /tmp, because I didn't want my logs under cvs, and then I tried the CVS commit again. This time, in the midst of a ton of cvs commit: Examining, I got a bunch of:

cvs commit: Examining .
cvs commit: Up-to-date check failed for `index-oracle.xql'
cvs commit: Up-to-date check failed for `index-postgresql.xql'
cvs commit: Up-to-date check failed for `index.tcl'
cvs commit: Up-to-date check failed for `index.xql'

And at the end it said cvs commit aborted!

It turns out that most of these Up-to-date things were files that I deleted but that I never cvs removed. So, one by one, I did a
:cvs remove index.xql

After I did that to all the failed files in a dir, then I did the cvs commit and it finally worked!

Next, I wanted to do the Tag, but the cvs tag command ironically expected the log directory to be in /web/myserver/, when the cvs commit didn't expect it. That's very confusing to me...I'm running the tag command in a directory WITHOUT a log/, and it returns:

T content-repository-content-files/readme.txt
cvs tag: Tagging log
cvs [tag aborted]: could not chdir to log: No such file or directory

Anyway, I'd do an ls and there was NO directory called log/ (I had moved it to the /tmp for the commit command...) So I finally was able to tag everything...I think...gulp...going ahead

Next I'm going to get the tar file of 4.6.3. Since I'm sshed into a machine that is in Texas somewhere (I'm in SF, CA), I don't know how to pop a browser and download the tar from the openacs site. If I had a URL, I could do a wget, but I don' I go to the site, download to my old local windows machine from a web browser, then I upload via ftp to my hosted account, and then I do a wget from the server to my hosting account (there's GOT to be a better way of doing that...) During the wget -- the terminal window starts repeating gibberish, ie:

6^M78% [===========================>        ] 6,712,292    316.07K/s    ETA 00:05^M79% [============================>        ] 6,806,132    317.03K/s    ETA\
00:05^M80% [============================>        ] 6,876,512    316.91K/s    ETA 00:05^M80% [============================>        ] 6,955,172    317.54K/s  \
  ETA 00:05^M81% [=============================>      ] 7,024,172    317.72K/s    ETA 00:04^M82% [=============================>      ] 7,119,392    319.07\
K/s    ETA 00:04^M83% [=============================>      ] 7,192,532    319.36K/s    ETA 00:04^M84% [==============================>      ] 7,256,012    3\
18.99K/s    ETA 00:04^M85% [==============================>      ] 7,326,392    318.84K/s    ETA 00:03^M85% [==============================>      ] 7,387,024\
    318.63K/s    ETA 00:03^M86% [===============================>    ] 7,443,692    318.21K/s    ETA 00:03^M87% [===============================>    ] 7,49\
8,892    317.51K/s    ETA 00:03^M87% [===============================>    ] 7,562,372    317.45K/s    ETA 00:03^M88% [===============================>    ]\
7,625,852    317.37K/s    ETA 00:02^M89% [================================>    ] 7,693,472    317.48K/s    ETA 00:02^M90% [================================>\
    ] 7,736,252    316.53K/s    ETA 00:02^M90% [================================>    ] 7,794,212    316.00K/s    ETA 00:02^M91% [============================\
====>    ] 7,860,452    316.05K/s    ETA 00:02^M92% [=================================>  ] 7,925,312    315.98K/s    ETA 00:02^M93% [=======================\
==========>  ] 8,010,872    316.55K/s    ETA 00:01^M94% [=================================>  ] 8,095,052    317.27K/s    ETA

At the end of the download, the file looks about 8.2 mgb, which is about right, but when I do the tar xvz openacs -- it hangs. It's not unpacking. I repeat the download, same thing...Going to bed now...will report back later...these are just a few of the types of things that we n00bs struggle with every day 😊