Forum OpenACS Development: Upload huge files

Posted by Eduardo Santos on
I'm trying to upload a huge file into using the the file upload in ad_form (400 MB). I've tried to change the the AOLServer parameters (max_file_upload_mb and max_file_upload_min in the new config.tcl), but I still can't upload the file. It seems like the server closes the connection in the beginning, without even try to upload it.

Any ideas on how to fix it? I'm using acs-core 5.3.0d1.

Obs.: I've tried to change the value in the stacksize parameter, but it was not successfull either.

2: Re: Upload huge files (response to 1)
Posted by Gustaf Neumann on
The configuration parameter depend on the version of the aolserver. In aolserver 4.5 the sizes are controlled via ns_limit. In case, you are using 4.5 add e.g. the following to the end of your config-file:

ns_limits set default -maxupload 100000000

3: Re: Upload huge files (response to 2)
Posted by Eduardo Santos on
Thank you very much for the tip Gustaf. It seems to be working right now. However, I had to put it mannually, instead of using the following instruction, in the end of config.tcl file:

if {[ns_info version] >= 4.5} {
ns_limits set default -maxupload [ns_config ns/server/${server}/module/nssock maxinput]

This instruction broke the initialization of AOLServer. I had to put the same code you supplied me:

ns_limits set default -maxupload [expr {$max_file_upload_mb * 1024 * 1024}]

Maybe you should change the config.tcl file in HEAD.