Forum OpenACS Q&A: Error during startup:invalid command name "dom"

Hi , can someone help me to understand what this error means? I installed alle the tcl/aolserver/tdom etc. and the permission are ok.

thanks in advance ----

[01/Aug/2003:09:05:33][32306.1024][-main-] Error: Error parsing queryfile /web/openacs-dev/packages/acs-tcl/tcl/00-database-procs-postgresql-postgresql.xql:

invalid command name "dom"

invalid command name "dom"
    while executing
"dom parse -simple [lindex $args 1"
    (procedure "xml_parse" line 4)
    invoked from within
"xml_parse -persist $stuff_to_parse"
    (procedure "db_qd_internal_parse_init" line 4)
    invoked from within
"db_qd_internal_parse_init $whole_file $file_tag"
    (procedure "db_qd_internal_load_queries" line 15)
    invoked from within
"db_qd_internal_load_queries $stream $file_path"
    (procedure "db_qd_internal_load_cache" line 9)
    invoked from within
"db_qd_internal_load_cache $file_path"
My guess is that you don't have tDom installed. Their is documentation for this on the HEAD documentation.
Another guess would be that you did *install* tdom, etc. But maybe you didn't *load* it in your service's startup script (i.e. your config.tcl file). Or, maybe you didn't restart your aolserver instance after changing config.tcl?
I load the modul and got th error:
'/usr/local/aolserver/bin/ cannot open shared object file: No such file or directory'
more idea? thanks
It looks like either you haven't built tDOM or you haven't installed the resulting .so file in your aolserver bin dir.
Posted by Nitish Bezzala on
I get the same error while installing AolServer4.10, with Tcl 8.4.9 and tDom 0.8.0 on Suse Linux Professional 9.2

I also get this error in the logs:

[08/Apr/2005:18:26:39][30435.16384][-main-] Error: 0-acs-init.tcl: error loading tdom: Tcl core wasn't compiled for multithreading.

In /usr/local/lib/ , it says

# Flag, 1: we built Tcl with threads enables, 0 we didn't

Any help is appreciated.


I recommend paying attention to the actual error message. As it says, you must build Tcl with --enable-threads for use with AOLserver; apparently you did not. Read and follow the OpenACS installing AOLserver docs.
Posted by Alessandro Landim on
64 bit users need to install tDOM from cvs.

Download tarball from and type the commands:

make install

Alessandro Landim

Posted by Klaus Hofeditz on

# ---
ns_param libtdom []
# ---

to config.tcl fixed the problem for me.

# ---
ns_param libtdom /usr/local/aolserver45/lib/tdom0.8.1/
# ---

You also want to check if $LD_LIBRARY_PATH is set.