Forum OpenACS Q&A: Forums broken for long pre tags?

Posted by Andrew Piskorski on
I was trying to post a question with rather lengthy examples, but clicking ok to preview it before posting to the forum just spun for a long time, then returned:

Invalid Request
The HTTP request presented by your browser is invalid.
Invalid HTTP headers
AOLserver/3.3.1+ad13 on
Browser is Mozilla 1.0.1 on RH Linux 7.3. This is very repeatable, if I use the same text I get the error above every time. About the only thing I associate in the text with the problem is that problem text has lengthy sections within pre tags. That seems to be related, anyway.

Anybody know what might be wrong? Is this a server problem or is it really my browser?

Posted by Dave Bauer on

I think its the same bug that checks the attributes that is broken for some search entries.

This bug:

Posted by Andrew Piskorski on
For future reference, it now appears that my problems submitting lengthy posts to Forums were due solely to a subtly broken network configuration on my end:

The Red Hat 7.3 box I was using appeared to be working fine. However, it had several suspicious networking symptoms:

  1. The problem above posting long messages to This happened with Mozilla 1.0.1, 1.4, and Netscape 4.79.
  2. When typing scp commands on the local box, scp from a remote server to the local box worked, but scp from the local box to a remote server would say 100% file transfer, then hang indefinitely with the file at zero bytes on the remote server.
  3. ssh connections worked fine, but setting CVS_RSH=ssh and accessing a remote CVS server would hang indefinitely.
  4. ssh -vX connections would appear to forward the X-Windows connection successfully, but launching any remote X application would lock up the ssh connection completely.

The solution? /etc/rc.d/rc.local was overriding the ethernet MAC address something like so:

ifconfig eth0 hw ether $MAC
If you want to override the MAC address, that's the wrong place to do it, as rc.local is executed too late in the boot process. If you really want to do that, the right place (at least on Red Hat 7.3) is in "/etc/sysconfig/network-scripts/ifcfg-eth0".

I did that, rebooted, and all the problems above went away. I did not then try to replicat the problem by putting the MAC address smashing back into rc.local - and I don't plan to. So I can't be entirely sure, but I strongly suspect that the late overriding of the MAC address was causing the weird network problems.