Forum .LRN Q&A: dotlrn can not send email

Request notifications

Collapse
Posted by Kayhan Bolukbas on
hi all!

I have installed dotlrn couple of days ago.
dotlrn is running on a redhat 8.0.

When i creat new users, system wants to send
emails to this user. But it can not send the
email and gives some error msgs like these:

"can not send email to mailto:xxx@xxx.xxx";
"can not connect to localhost:25"

Also the Maillog file says something similar.

i could't solve the problem yet.
Can anybody help me?

thanx.
Kayhan

P.S qmail is the MTA.

Collapse
Posted by Malte Sussdorff on
Can you make sure qmail is running? (e.g. telnet localhost 25 should give you a response from qmail).

Does it work when you just use "mail mailto:myaccount@myemailprovide.com";, thereby sending a mail to your mail account (after entering the subject just type some text. You can send the mail by having a "." in a single new line at the end).

Collapse
Posted by Kayhan Bolukbas on
both don't work.

this means my qmail doesnt work.
how can i get it run.

1 more note, if i do
"./config-fast"  for qmail.
there was a space for host name.

Collapse
Posted by Kayhan Bolukbas on
i configured qmail again and it is running now.
also i have tried "mail" command and it sent mails.

But dotlrn still doesnt send mails.

Collapse
Posted by Jade Rubick on
You might need to configure something in the config.tcl file. I seem to remember something about that?
Collapse
Posted by Andrew Piskorski on
I'm assuming dotLRN still uses ns_sendmail to send mail from AOLserver, like OpenACS has for years. So, in your AOLserver config.tcl file, look in the ns/parameters section and check the values, if any, that you have for these parameters:
smtphost, mailhost, smtptimeout, smtpport
For most people, simply not setting any of those at all will do the right thing. But if you have an atypical mail server setup, you'll need to specify non-default values for some them. You have qmail running on the same box so you don't need to set smtphost at all, but maybe it is set, but to the wrong value?
Collapse
Posted by Derian Jesús Dorado on
Hi all!!

i have now the same problem.
How it was solutioned that problem ?

Thanks

Collapse
Posted by Raúl Morales Hidalgo on
Are you sure you have your mail server set up correctly?
Either you don't have it set up or you have it configured on another port.
Collapse
Posted by Volin Karagiozov on
Check if tcpserver is running:
ps ax | grep tcpserver
You should get something like that:

2275 ? S 0:01 /usr/bin/tcpserver -v -R -l yourhostname.yourdomainname -x /etc/tcp.smtp.cdb -u 503 -g 502 0 smtp /var/qmail/bin/qmail-smtpd

If it is not running than it means that you did't install correctly ucspi - the program that handles incoming tcp connections. (See OpenACS Core Documentation / Appendix B. Install additional supporting software/ Install qmail / Install ucspi)

Also look /var/log/maillog file - to see qmail logs.

Collapse
Posted by Derian Jesús Dorado on
Thanks for your help.

My problem was in the /var/qmail/control folder and the config files. also I purged Exim.

thanks Very much.