Forum OpenACS Development: Re: HEAD problem with package repository installer

Posted by Lars Pind on

This sounds serious. Can you be a bit more explicit, please.

Let's focus on the box that's having problems ...

1) You install OpenACS using the bootstrap-installer

2) You visit /acs-admin/install and installs from local file system .. which packages?

3) The SQL files do not get sourced.

Is that the scenario?

I'm fairly confident it doesn't have anything to do with the PG port. We routinely have PG running on different ports.

But I did experience a problem with the new installer not sourcing DB files right, because the paths wasn't constructed just right. But I fixed what I found.

Are you 100% up-to-date on the code?


Posted by Mark Aufflick on
nearly - the only time it worked was when i had a package in the local file system and used the old installer (/acs-admin/apm/packages-install). Using the new installer, the packages get downloaded correctly, but the DB files are not sourced whether the package is already in the file system or not.

Running QDDebug and postgresql in full debug has yielded no info, so nothing seems to be hitting (or attempting to hit) the db connection pools.

It could be a filesystem location since I am not following the standard /web convention on that server, and the server that works is.

I was 100% up to date on both servers when I ran the tests yesterday (I double checked) and a quick check of the core packages shows no cvs diffs since then.