Forum OpenACS Q&A: Re: Problems Loading Postgres Drivers

Posted by Rod Cap on
I've copied from another server only the binary, and then I kill all the nsd and:
./nsd-postgres -t /web/service0/etc/config.tcl
But it throws the same error in the browser, now in the error log I found :

Warning: modload: failed to load '/usr/local/aolserver/bin/': ' cannot open shared object file: No such file or directory'

Error: dbdrv: failed to load driver 'postgres'

Error: dbinit: no such default pool 'pool1'

What should I do??

Posted by bill kellerman on
This can be solved a couple of different ways...

Add the path '/usr/local/pgsql/lib' to your LD_LIBRARY_PATH shell variable before starting aolserver process (using "set" or "setenv" command depending on your shell).

Or add the path to the file /etc/ and then run the command

Neither of these worked for me (I was using freebsd though).  I made a
soft link from /usr/lib/ to the pgsql directory:

% ln -s /usr/local/pgsql/lib/ /usr/lib/

Make sure the user starting aolserver can read from this directory.