Forum OpenACS Q&A: Re: Problems Loading Postgres Drivers

Posted by Rod Cap on
Thanks for your patience Derek.
Now it load the postgres drivers but..
In the browser it says OpenACS Installation: Error
OpenACS could not allocate a handle from database pool "pool2".

I have no idea...
Thx, for your time

Posted by bill kellerman on
hmm...  i'm not sure what causes that.

check this thread:

make sure you have your database server and username specified correctly.

Posted by Selim Erol on
I recently installed OpenACS on Linux Ubuntu 9.04 and got the same error when loading localhost:8000 for the first time. (I used the installation instruction on

What actually solved the problem was killing the aolserver4-nsd process and restarting openacs.

Only restarting openacs didn't work..

Seems to be too simple to be a good solution but it might help someone out there.

Posted by Andrew Piskorski on
How do you "restart OpenACS" without restarting AOLserver? AFAIK there is no such thing, it can't be done. Therefore, I think what you actually found is that your "restart OpenACS" script didn't work right. It probably tried but failed to shutdown and restart AOLserver. You might want to look into just what your script is doing and what went wrong.