Forum OpenACS Q&A: fail to register

Posted by Clif Flynt on
I'm running on RedHat Linux 6.1, with Postgres 6.5.1 (or maybe 6.5.3).
The AOLServer and ArsDigita/Postgres are running on one box, connected
via 10-Base-T to the Postgres server on another box.

I've installed aolserver 3_0rc1, and the aspg downloaded on 3/18/00.

The database install looks good, and the server seems to start up OK.

Loading index.tcl works, and the first two screens of registration
are OK.

When I submit: register/user-new.tcl (the screen with password
and web page requests),  the browser displays:

Server Error

The server encountered a configuration or operating system error while
attempting to
satisfy your request.
I don't see any error message in the log files.  The last message
in the log is:49-] Notice: nsd.db: sql(
select spam_id, creation_user, from_address, body_plain, body_html,
body_aol, title, user_class_query, user_class_description, send_date,
status, last_user_id_sent, template_p from spam_history
        where send_date::date <= sysdate()::date
        and (status = 'unsent' or status = 'interrupted')
        order by send_date
[20/Mar/2000:00:00:48][7480.14342][-sched:49-] Notice: Querying 'end
[20/Mar/2000:00:00:48][7480.14342][-sched:49-] Notice: Ns_PgExec:
Committing transaction
[20/Mar/2000:00:00:48][7480.14342][-sched:49-] Notice: nsd.db:
sql(  end transaction

Any ideas where to look next?

Posted by Ben Adida on
You should try giving us more of your error log. Also, did you download ACS/pg beta1 or beta2? Check the readme.txt file.
Posted by Clif Flynt on
Beta2, already???

I was running with beta1, just downloaded beta 2.

There is an error message that I missed higher up in the log:

... Error: nsd.tcl: syntax error in expression ""
syntax error in expression ""
    while executing
"if [ad_need_cookie_chain_p] {
    if { [ns_conn driver] == "nsssl" } {
        set protocol "https"
    } else {
        set protocol "http"
    (file "/web/server1/www/cookie-chain.tcl" line 39)
    invoked from within
"source $script"
    (procedure "ns_sourceproc" line 7)
    invoked from within

The problem turned out to be that I'd missed several of the yourservername edits in ad.ini, and the ad_parameter procedure was returning a "".

Posted by Marshall Trammell,III on
I have loaded AOLserver3.0  : seems ok, serves adp & tcl & reads pgdb
my datamodel.txt shows no errors --- it took a long time to load
startup log shows 2 or 3 errors
one I think had to do with user groups

Problems are
1) login only works when specifying the index.tcl file

2) when trying to log in as a valid user ( not a new user)
   script fails with the following:
   Error:/tcl/user_group_defs.tcl:function ug_serve_group_pages:first
   element in url list is not [ad_parameter GroupsDirectory ug]

   I also notice that this call logs a notice showing the url
   but mine is "/" ; that is nothing but a slash

3) In addition, startup nsd.tcl looks for a directory that has not 
   been created for redirection.  
   any help would be appreciated. I'm a little stumped.

Here are the detailed log files in the order they were created.

[15/Jun/2000:21:30:44][2568.1024][-main-] Notice: nsd.tcl: sourcing: /web/server1/tcl/ad-redirect.tcl

The config path below can't be correct can it. I put that notice in myself.

[15/Jun/2000:21:30:44][2568.1024][-main-] Notice: Config Path:ns/server/server1/acs/redirect
[15/Jun/2000:21:30:44][2568.1024][-main-] Notice: All the redirects :
[15/Jun/2000:21:30:44][2568.1024][-main-] Error: nsd.tcl: invalid set id: ""
invalid set id: ""
    while executing
"ns_set size $all_the_redirects"
    invoked from within
"ns_log Notice "/tcl/ad-redirect.tcl has found [ns_set size $all_the_redirects]..."
    invoked from within
"if !$ad_redirects_installed_p {
    # we haven't done this already
    set ad_redirects_installed_p 1

    # we could use ad_parameter_section (define ..."
    (file "/web/server1/tcl/ad-redirect.tcl" line 12)

not really concerned about address book now

[15/Jun/2000:21:30:44][2568.1024][-main-] Notice: nsd.tcl: sourcing: /web/server1/tcl/address-book-defs.tcl
[15/Jun/2000:21:30:44][2568.1024][-main-] Error: nsd.tcl: can't use non-numeric string as operand of "&&"
can't use non-numeric string as operand of "&&"
    while executing
"if { !$address_book_procs_scheduled_p && [ad_parameter SendBirthdayAlerts addressbook] } {
    set address_book_procs_scheduled_p 1
    # schedul ..."
    (file "/web/server1/tcl/address-book-defs.tcl" line 205)

I haven't a clue about this error mesage.

[15/Jun/2000:21:30:45][2568.1026][-sched-] Notice: Ns_PgOpenDb(postgres):  Openned connection to localhost::acs.
[15/Jun/2000:21:30:45][2568.1026][-sched-] Notice: Querying 'set datestyle to 'ISO';'
[15/Jun/2000:21:30:45][2568.1026][-sched-] Notice: Querying '
    select '/' || group_type as group_type_url from user_group_types 
    where has_virtual_directory_p='t';'
[15/Jun/2000:21:30:45][2568.1026][-sched-] Notice: nsd.db: sql(localhost::acs):  
    select '/' || group_type as group_type_url from user_group_types 
    where has_virtual_directory_p='t'
[15/Jun/2000:21:30:45][2568.1026][-sched-] Notice: Done running scheduled proc ug_init_serve_group_pages.
[15/Jun/2000:21:30:45][2568.1026][-sched-] Error: nsd.tcl: expected boolean value but got ""
expected boolean value but got ""
    while executing
"if {[ad_parameter EnabledP ccstub]} {
	proc cc_send_to_server_21 {command in_data out_data} {
	    stub_cc_send_to_server_21 $command $in_data $out_da ..."
    (procedure "ccstub_enable_stub" line 2)
    invoked from within

5: fail to register (response to 1)
Posted by Marshall Trammell,III on
my configuration for above problems is as follows:

I am using nsd.tcl and server1.tcl as config files
with aolserver3.0

files are being sourced ok except for the above errors.

I downloaded postgres 7.0.2, the acs, and driver last week
from the openacs site (except postgresql)


My ad.tcl file was not getting sourced.
ad_parameter was not returning anything correctly
so I put my source command at the end of my nsd.tcl config file
seems like it ought to come before private library declaration though

it's 2:00AM here and i feel it 
bye all
Posted by Don Baccus on
If you're using Tcl configuration rather than .ini configuration, you must use "source" rather than the private library parameter.

This is a bit confusing if you've used earlier versions of AOLserver or are switching from the traditional .ini style of initialization to the new Tcl style.

Posted by Don Baccus on
Damn, I forgot to flag that last post as HTML...let's see if this gets us back on track.