Forum OpenACS Development: Re: OpenACS performance issues

Posted by Matthew Coupe on

I take it we need to increase this value too?
What would you recommend?

#Change the kernel parameter for maximum shared memory segment size to 128Mb: DAVEB: How current is this? Do modern 2.4 or 2.6 kernels have such low settings? This is highly dependent also on the amount of RAM on your server, most realy servers have gigabytes of RAM so adjust accordingly.

[root root]# echo 134217728 >/proc/sys/kernel/shmmax
[root root]#

Make that change permanent by editing /etc/sysctl.conf to add these lines at the end:

# increase shared memory limit for postgres
kernel.shmmax = 134217728