Forum OpenACS Q&A: Error: sec_read_sercurity_info

Hi! I had problems when I tried to see the main page of the acs. I
have followed all the instruccions, then I run the nsd.ini file and
everythings it's ok, but when I wanna see the main page or the
/register page it show me this error: "an error has ocurred", then I
see my aolserver running with -ft and it shows...

error ns_pgexec: resultstatus: 7 message: error: no such function
"bpchar" with specied atributes
error: filter sec_read_security_info 1 row failed (exception NSDB,
"query was not a statemente returning rows")...

Can somebody help me,

well, finally I decided to install postgres 7 and it works fine!! I don't know what was happening but now everything is ok.. :o) excelent work everybody at openacs... !!!
Posted by Eric Soroos on
I can replicate this problem. Or more precisely, I am currently
replicating this problem. (rh 6.1, pg 6.5.3, openacs 3.2.2b3,
aolserver 3.0 release)

off to try 7.0...


Posted by Don Baccus on
OpenACS currently requires PG 7.0, the latest production release of the database engine.

Shouldn't be a terrible surprise, after all ACS Classic requires things like "on delete cascade/set null" that only came with Oracle 8*