Forum OpenACS Q&A: Re: Missing tclsh on Solaris - how to fix?

Posted by Andrew Piskorski on
You're using "cc", but what compiler is that on your machine? Sun cc or gcc? You might be using the wrong one, or using the options intended for the other compiler, or something like that.

I never tried building tdom on Solaris but I think your compile error above is for Tcl anyway, not tdom. Whenever I've built Tcl from source on Solaris it Just Worked. I last did it like this:

$ cd checkouts/tcl/tcl-842/unix/
$ ./configure --enable-gcc --enable-shared --enable-threads
# env CC=gcc gmake
$ gmake
$ #gmake test
  # Files with failing tests: http.test httpold.test safe.test
$ sudo gmake install 
$ sudo chmod 755 /usr/local/bin/tclsh8.4
I'm not sure why I had that "env CC=gcc gmake" commented out in my notes above, but you might need or want to use that rather than the just plain "gmake" that I suspect worked ok for me.

If you're using AOLserver 3.3+ad13 and it's Tcl 8.3.x, I've no idea whether a tdom compiled with Tcl 8.4.x would work there or not. But wait a minute, for use in AOLserver 3.3, you have to compile tdom specially as an AOLserver module anyway, and AOLserver 3.3 ships with its own customized copy of Tcl 8.3.x, so isn't that what you should be using for building your tdom?