Forum OpenACS Q&A: Re: setting up a second OpenAcs instace - problem loading

thank you dave, but the problem is not the path I don't think.
When using the version of OpenAcs 5.4.1 downloaded yesterday I run into this problem.
When using a version downloaded a week prior all is well.

I have checked what you suggested and it is fine. It appears to be something in the new download OpenAcs 5.4.1 that is causing this.
The problem is that I don't know where to look (the config file is not the issue as I am using literally the same one in both cases)

A couple of questions:

Where is located in your system?
What are the permission on the shared lib and its path?
Under which user runs your nsd?


[root@vps ~]# ls -al /usr/local/pgsql

drwxr-xr-x 3 postgres web 2048 May 17 01:11 lib

lrwxrwxrwx 1 postgres web 12 May 17 01:11 ->
lrwxrwxrwx 1 postgres web 12 May 17 01:11 ->
-rwxr-xr-x 1 postgres web 111295 May 17 01:11


nsd is run in both situations by the same user who is member of the web group

You are sure, this is the libpq, which was used for linking with When you are on linux, try "ldd /usr/local/aolserver/bin/" to check the path.

We had a few years ago the problem, that psql worked perfectly, but aolserver was not able to load nspostgres. The problem were default permissions on the system that were used during the make install.... since aolserver switches to the specified user+group before loading the .so files, things went wrong withing aolserver. Sounds suspiciously like what you are seeing.


problem solved, silly syntax...

there was a mistake in the run script in daemontools. Indeed the issue was $LD_LIBRARY_PATH not being set.

thank you both for your help