Forum OpenACS Q&A: Re: Problem Installing The Jabber Package

Posted by Andrew Piskorski on
The problem the compiler is having at line 59 doesn't mean the error, if any, is actually anywhere near line 59. It could be much earlier. Maybe it could even be in another file altogether, although I'm not sure about that.

Since I coincidentally already had it checked out from CVS (even though I never use it), I looked briefly at the contrib/packages/jabber/ stuff (from the oacs-5-0 branch, I think the CVS Head is the same):

The way the nsjabber C code is provided is rather weird, there're a bunch of tar and tar.gz files checked into CVS, and the c/nsjabber- nsjabber-patch-1.tar.gz tarballs seem to have a lot of overlap in what they contain. That shouldn't be direct directly related to your build problems, but it seems sufficiently odd and disorganized that I'd probably ask the mainters of that jabber contrib package about it.

I went ahead and tried to build it, but the build stopped even sooner than yours did, probably because my machine doesn't have something installed on it that yours does:

$ make
gcc -I../include/xode  -I../../include -I../include/jabber -I../include -I../../nsd  -I../../include -D_REENTRANT=1 -DNDEBUG=1 -g -O2 -fPIC -Wall -Wno-unused -mcpu=i686 -DHAVE_CMMSG=1 -DUSE_FIONREAD=1 -DHAVE_COND_EINTR=1   -c -o jpacket.o jpacket.c
In file included from jpacket.c:20:
../include/jabber/jabber.h:42:21: libxode.h: No such file or directory
make: *** [jpacket.o] Error 1
Posted by Steve Manning on
Yes I had problems early on with a missing include dir that turns out to be in the ns-jabber-patch tarball which I'd originally missed. Your compile failed because libxode needs to be present. As you say its a mess but I can't attribute anything in there to my problem. I ran Dos2Unix over the files and it didn't find anything to change so I don't think its a DOS file problem. I'll try an email to the maintainers directly.

Thanks for trying.