Forum OpenACS Q&A: Can't load - library not found. HELP!

When I run AOLserver, it gives me a "Warning: could not load
/home/aol30/ cannot open shared
object file: No such file or directory".  I did everything specified in
the installation directions - I set the path in and then
ran ldconfig (I even ran ldconfig -p, and WAS listed),
and then when that didn't change anything, I added the
LD_LIBRARY_PATH lines to my /etc/profile.  I still keep getting
this error.  I've set up the entire OpenACS system on another
server, and everything was working fine.. the only difference is
that last time, I used the RPM's, and this time, I compiled source
(with 16k block size).  Can anyone please help me?  I'm on a
tight deadline, so I'd appreciate ANY suggestions you might
have.  Thank you!
This will probably solve your problem. Let us know if it doesn't. Taken from the documentation:

If you are running PG 7, make a symbolic link from pointing to because AOLserver looks for when
loading the driver:

cd /usr/local/pgsql/lib

ln -s (as user postgres)

Okay, I feel stupid.  Sorry about the alarm - it turns out I hadn't set
my pgsql directory to be executable.  I thought I'd done that.
Problem solved.