Forum OpenACS Q&A: access denied to site-wide administrator

while logged in as site-wide administraor, I still get a message that
I do not have access to certain pages including event admin. My guess
was that I needed to create a new group, and put myself in it, but I'm
not sure. On the same note, How do I edit a current user's roles.( For
instance, make user a site-wide administrator)
Posted by Don Baccus on
Second question is easiest - you make a user a site-wide admin by adding them to the "system administrators" user group.

As far as the first question, administration in the ACS has been an evolutionary thing, with various modules taking different approaches based on when they were written (usually for a specific client of Ars Digita).  So there's a woeful lack of consistency.  The doc pages for each module should talk about module administration.

Cleaning this up and presenting a uniform administration style is one of the goals of ACS 4.0.

Posted by Avni Khatri on
As a site wide admin:
1. go to /admin/ug/
2. click on the Administration group type
3. click on the Events Administration user group (it should already exist)
4. add yourself as to the group

This should give you access to /event/admin/
Posted by Hubert Tsang on
I can't get to /admin/ug as system/changeme. The webserver responds with error 404, file not found. I can see that the directory is there, when I look at the file system.
Posted by Avni Khatri on
Weird. What's your url? Does the error log say anything?
Need more details to help you. What have you tried so far?
Posted by Hubert Tsang on
I got it working. It was trying to redirect to https and I was running https at 8443, instead of the normal port.