Forum .LRN Q&A: Re: Help Needed in Setting up .LRN to Scale

Posted by Janine Ohmer on
Time for an update.

I've tried cutting down Oracle's SGA so that the system is no longer using swap.  Didn't help.  I've tried moving the temp datafile, which was causing a lot of disk activity on the external RAID array, to the internal drive.  I've tweaked the net8 files, and looked at things every which way.  Found a few things not quite right, but nothing to fix the problem.

One major issue I still need to resolve is that the Oracle is version  I'm going to installt he patchset as soon as someone in Germany can make the installation CD available, and I'm crossing my fingers that it will help.

I took the query from /dotlrn/admin/users and tweaked it every which way.  What I found was that it's slow if it has to transfer rows from the database, even if it's only to do an order by.  If there's no ordering and it's only returning a count then it's lighting fast, even with the two permission calls.  Does this ring a bell for anyone?

I have no doubt that we will need to tweak the application to get this working, but until I can get decent performance out of sqlplus it seems rather pointless to try.