Forum OpenACS Development: Re: aolserver/postgres hang

Posted by Andrei Mitran on
Yes, the nspostgres version that I have is correct.

I had to get the system up this week so I went back to OpenACS 4.6.3 with aol 3.3oacs1 and the same version of Postgres (7.4.2). I had to fix some varbit stuff in postgres.sql in the kernel pkg, but other than that, everything works flawlessly on Suse 9.1.

My conclusion is that it is definitely not a Postgres 7.4.2 problem since it works with other versions and I can drop tables all day long in a transaction by hand. It is also unlikely that it is a Suse problem since everything works with older versions. I don't think that a db_transaction with a dml statement that drops a couple of tables is likely to be the problem either especially since you have it working on redhat and I ran the package manager to drop all the tables in a package and got the same hang as my code. So, I am almost certain it is the nspostgres driver – probably related to the complier warnings which I haven't had time to figure out yet.

I still would like to use 5.1 - but it might be a while until I have time to figure out the driver problem. Hopefully someone else has seen and solved this already.