Forum OpenACS Q&A: Re: Problem Installing The Jabber Package

Posted by Bjoern Kiesbye on

I have uploaded the nsjabber- to the file storage, this version works with Aolserver 4 (only).

You are able to compile the old version with Aolserver 3 after editing the Makefile but the conferencing System will not work, due to a change in Aolservers ns_set c-api. As well it includes all changes (speed enhancement) and bug fixes, since the last release.

Posted by Tom Ayles on
Hi Bjoern,

Thanks for making this update available. Unfortunately, I seem to be having some trouble with the file - gunzip complains about 'invalid compressed data--format violated' and won't decompress it. I've tried a couple of different means of getting it, so I think it's a server-side problem; maybe this is related to the recent hardware failure. Any chance you could check the file? (or maybe even send it to me directly!) I'm evaluating the module for a project right now, so far it looks very promising!


Posted by Jeff Davis on
Bjoern, there was a bug in file-storage upload (under aolserver 4 and another thing that has been fixed since 4.6.3) which corrupted binary files. I fixed it so if you could upload your file again that would be great.