Forum OpenACS Development: Response to Big honkin' commit now available ...

Posted by Vinod Kurup on
I ran into a problem when loading this under PG (7.1rc1). The datamodel loads, but acs-kernel fails :
Failed to install ACS Kernel, version 4.2. The following error was generated: 

     Database operation "0or1row" failed (exception NSDB, "Query was not a statement returning rows.")

Package enabled. 
The error log shows:
[05/Apr/2001:18:45:12][8255.25605][-conn4-] Error: dbinit: error(localhost::openacs-4,ERROR: ExecAppend: rejected due to CHECK constraint apm_package_vers_desc_for_ck ): ' select apm_package_version__new( '', 'acs-kernel', '4.2', '', 'Routines and data models providing the foundation for ACS-based Web services.', '', '', '2001-03-06', 'ArsDigita Corporation', '', 't', 't'); '
There's a check constraint on apm_package_versions that the description_format should be either "text/html" or "text/plain", but we're trying to set it to '' (the fifth argument). I think this is the old '' vs NULL issue, because if I enter the above command with NULL's instead of empty strings, it works. If I fix this issue, the same issue comes up later in apm_package_version__add_file (can't enter '' for db_type, because of foreign key violation). Am I missing something?

I then tried to load via Oracle and everything works beautifully!!! (8.1.6 EE). Really, REALLY cool!