Forum OpenACS Q&A: Response to aolserver running crazy...

Posted by David Kuczek on
Hello Connie,

my nsd.tcl says:
ns_section "ns/db/drivers"
ns_param postgres ${bindir}/ ;# Load PostgreSQL

and the is inside /aolserver/bin too.... It worked well until today.

I was messing around with shared memory because on it says:

The default shared memory limit (both SHMMAX and SHMALL) is 32 MB in 2.2 kernels, but it can be changed in the proc file system (without reboot). For example, to allow 128 MB:
$ echo 134217728 >/proc/sys/kernel/shmall
$ echo 134217728 >/proc/sys/kernel/shmmax

after that I started postgres with a 8000 -B flag and it worked. It even appeared to be quite quick. With ipcs I saw that 64mb were allocated to postgres.

But somehow my aolserver doesn't find this funny at all...