Forum OpenACS Q&A: Overcoming new-file-storage 2,000,000 byte limit?

I just tried to upload an openacs-3.2.5-1.noarch.rpm into the
appropriate place under Alternative Distributions.

It died after a long wait and told me I couldn't upload a file larger
than 2,000,000 bytes, hit the back button and fix the problem 😟

Can we double that limit or something?  If not, new-file-storage is
going to be useless for handling RPMs and SRPMs of this sort of size.

this is a configurable parameter, I will change it.
Thanks Ben, let me know when it is done and I'll retry the upload.
should be fixed now.
The problem persists in dotLRN 2.0b4(OpenACS 5.0b4). I am unable to upload files exceeding 2,000,000 bytes.

I changed the parameter for attachment under OpenACS-wide administration. It did not make a difference.

I also changed the "MaximumFileSize" in under the File-Storage package. No success. Do I need to re-install after changing the .info? Is there anything else I could do?

Please help.

Possibly you are setting only the default value, not the value actually used by the "instance" of the package?  The former is done in /acs-admin and the latter in admin (Site Map).
Thanks for your response, Joel. I changed the parameter of the file-storage instance under sitemap, unmounted/mounted the instance, even rebooted. Still, no success!

Specifically, I get following error message while uploading a 2.5MB zip file to one of the course public folders.

We had a problem processing your entry:

    * Your file is larger than the maximum file size allowed on this system (2,000,000 bytes)

Please back up using your browser, correct it, and resubmit your entry.

Am I missing something obvious?

Problem solved! Joel was right. Solution was indeed under the admin sitemap, but deep under the instance hierarchy. Earlier I had just scratched the surface at the file-storage instance at the top level of the dotlrn. The full traversal of the department/subject/class hierarchy revealed specific file-storage instances for each of the classes with configurable MaximumFileSize parameter.

Thanks again, Joel!