Forum .LRN Q&A: Problem with spanish localization under LRN 2.0.3


(sorry about my english)

I've installed .LRN 2.0.3 under Oracle 8.1.5 and I've surprised about an strange behaviour with the spanish localization. I've tried to apply many of the post's solutions about charset encoding, but I couldn't solve it. Perhaps anyone can help me.

When I start the service I receive all the interface messages with character problems i.e. can't see any accents, letter ñ, etc. but it appears the two utf-8 chars. i.e: instead of "é" I see "C)". If I go to the "Administration of Localization" and disable the Spanish locale and then I enable it again, I get all the chars in the interface correctly. Although I can never see it right inside forms. If I stop the service and restart again, I get again the bad two-chars!

I tried to define the charsets in the config.tcl with several parameters, such as:
ns_param  HackContentType     true
ns_param  HttpOpenCharset     iso-8859-1
ns_param  OutputCharset     iso-8859-1
ns_param  URLCharset        iso-8859-1

and tried it with many charsets, iso-8859-1, UTF8, etc. but it didn't work.

I'm using:
-dotLRN 2.0.3
-Oracle 8.1.5 with UTF8 charset
-TCL 8.4.6
-AOLServer 4.0.5

Can anyone give me a hand? Thanks


Galileo tiene esto:
ns_section ns/parameters

# Unicode by default:
# see
ns_param  HackContentType    1
ns_param  DefaultCharset    utf-8
ns_param  HttpOpenCharset    utf-8
ns_param  OutputCharset      utf-8
ns_param  URLCharset        utf-8

Y una configuracion similar, usando postgres y todo funciona bien.

Por que no pruebas una version mas reciente de dotlrn? desde cvs el branch oacs-5-1. Y un oracle mas reciente ...

I've set in environment:


and recreated the database and it seems works fine, at last!


Posted by Andrew Piskorski on
I don't think this has anything to do with the problem you were having above, but why are you using Oracle 8.1.5? You're probably the only person in the entire world running dotLRN on a version of Oracle that old. For Oracle 8i, you should be using version