Forum OpenACS Development: Response to What naming conventions to follow?

Posted by Luke Pond on
I'm also in favor of disambiguating parameter names in plpgsql with the "p_" prefix.  It's easier to read than "function_name__", especially when the function name is something besides "new".  It also visually matches the convention of "v_" as the prefix for local variable names (which is occasionally followed by arsdigita).

It's not too late to reach a consensus among the non-core package porters, and put this in the Guidelines document as a coding standard.  Since there's nothing in there at the moment, people will inevitably make up their own schemes for parameter and variable naming.