Forum .LRN Q&A: Re: Debian package of .LRN - Error after install

Posted by Patrick Rebscher on

i really appreciate your work !
Unfortunally i do have a problem:

I have installed the package with
apt-get install dotlrn postgres
I used the default values.

Then i modified the file

I changed the used ports to
80, 443 because of the Post from Jade Rubick. I then changed the aolserver4 ports to 8000 8443.

I could configure the package in the browser (i use lynx on the local console), after that the server wasn't reachable again. I also tried some restarts of the db and the server.

You can see this situation in my Error-Picture

I then tried to change the entries in
to trust, but that didn't help.

As the connection is aborted, when i connect to ssl i searched for possible errors there.

I found this lines in the logfile.
no SSL contexts defined for this server
no SSL drivers defined for this server

I do think this is my main problem, but i don't have any clue how to fix it.
I thank you for your patience reading so much text and maybe helping me now 😊

Greetings Patrick>
Posted by Otto Solares on
You could check the package for dotlrn-2.1.0b1 in:

deb binary/

It fixes a lot of problems.



Posted by Patrick Rebscher on
Hi Otto,

i tested the dotlrn-2.1.0b1 but i have the same problems as with 2.0.3 😟

Maybe i only need some advice with the SSL capabilities.
How do i create the needed certificates ?
I won't need a CA or something realy secure, because i am just testing everything in a VMWare.

Thank you,


Posted by Otto Solares on
You can create certificates with the mkcert tool:

And a working SSL configuration in the .tcl config file.