Forum OpenACS Q&A: Response to can't grep nsd with ps aux...

Posted by Jeff Davis on
On linux "ps aux" will give different results than
"ps aux | cat"; If you do "ps auxww | grep nsd" you will see the full command.  ps tries to figure out how wide your screen is and truncates the line there.  For pipes it seems to assume 80 characters by default absent the w flag.